Grandstream GXP2120 and Asterisk in call feature codes

If anyone is using the GXP2120 phones from Grandstream PLEASE help.

Is there a special setting on the phone to allow/recognize Asterisk in call feature codes?
I can’t get *2, ##, ** or any other in call feature code to work on this phone. With other Grandstream phones I simply disable “phone call features” and that allows Asterisk call features but with this phone it does not work. Help!

I have Grandstream GXP2010 which should be the same. We usually use the Transfer button rather than the *2 combination but I tested it, and it works. What version of the firmware are you running on the phone? I"m on with Bootloader

There is a setting under the account tab called “Enable Call Features:” which you will want to be set to YES to support star codes.