Grandstream configuration, history includes + symbol

I’m having a hard time googling this one, because of the symbol involved, a ‘plus’ or +. Whenever I dial a number on my grandstream phone (2170), it adds a ‘+’ to the history number. So if I dial 7155551234, it stores ‘+7155551234’ in the history. When I go to redial from the history, or the ‘redial’ button, it tries to dial:
’+7155551234’ and the phone returns a ‘404’ error. I can’t seem to strip these with FreePBX’s outbound route dial plan filter (prefix), and I don’t see any options to remove it on the phone. I’m a little lost.

Anyone have any advice?

Just guessing, try setting Send RPID for the extension to no. If that’s not it, look at the SIP responses for any headers with +. If none, the phone must somehow be adding it.

Holy buckets,

That worked! Not that it matters, but the extension was set for ‘send p asserted identity’; changed to ‘no’ and it works.

Thanks, been driving me nuts!

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.