Google Voice + SIP client configuration

I’ve Googled this problem for a couple days now and have searched the forums, but a lot the thread are for naught.

Using AsteriskNOW v3.0.0 64bit inside a Virtualbox VM with bridged networking. Everything is up-to-date via yum and through the FreePBX Module Admin (except a handful of modules that require FreePBX Framework). Have a local DNS and static DHCP routed to the VM (AsteriskNOW.internal []); and have TCP&UDP port forwarding to RTP 10000-20000, SIP 5060-5082 + 5223 (Regular SIP?) + 5222 (GV SIP) as per (series suggested in thread). Reason I allowed both TCP and UDP was that I figure the client will pick which protocol to use with a preference towards UDP.

Client-side I have Linphone, X-Lite, and Zoiper installed. Using the Youtube series I made an extension “Google Voice<100>” and routed that for in-outbound calls. Inputting the username-domain into the clients [email protected] (or even my DDNS from, I can see the clients connect but cannot make calls.

Not sure why the setup isn’t working, can I ask for some guidance?

These are all the modifications I remember making.

Asterisk SIP Config:
IP Configuration=Dynamic IP
Dynamic 120 Refresh Rate
Local Networks=

Advanced Settings:
Display Hidden Settings
Show all Device Setting on Add=True

Extension 100:
Display Name=Google Voice
CID Num Alias=10-digit GV #
SIP Alias=Jay

Google Voice (Motif):
Std. Account Info
Edit Truck=checked
Edit Outbound Routes=check
Send Unanswered to Google Voicemail=checked

Inbound Route:
DID Number=10-digit GV #
Destination=Extension <100>Google Voice

Outbound Route:
Just added a pattern=+1NXXNXXXXXX
Also put 10-digit GV # as CallerID

No other changes than adding/creating an account with the following information:
Username=100 OR AsteriskNOW.internal
Password=secret set above

LinPhone: Cannot connect.
Zoiper && X-Lite: Connects (visible on System Status report), but cannot call.

There was an error on the Web GUI so I reinstalled AsteriskNOW onto a new VM (this time taking snapshots along the way). Well I don’t know what happened, but it works! Might it be having to re-enable FreePBX Framework after a yum update?

I would also recommend against Linphone. Unless there is something profoundly different in the default setup, it will not connect to Asterisk. Zoiper seems to work right out of the box and has a nice UI, so I’d recommend that.

deztox - Why did you use Asterisk Now instead of the FreePBX distro?