Google voice outgoing and google voicemail questions

Two google voice questions. I got google voice implemented with my trixbox. Sounds though like I can’t fudge the outgoing caller ID? It shows as my google voice #, I want it to show my home #? Google searching looks like I can’t do that.
I’m using google voice as a outbound route. My incoming route is flowroute.

And then question on voicemail…

So here’s the setup:

Incoming calls to my home # go to my freepbx, and ring my “home” phone (extensions), and my cell phone via follow me.
I want my voicemail to go to Google Voice.

So - here’s the catch.

Basically, unless I’m missiong something obvious, the only way to do it is have my cell phone do the ‘voicemail’, right?

So the catch is if my cellphone is off, and someone calls my home, it will really only ring once before it goes to my cell phone voicemail. I can’t disable voicemail on my cell phone, otherwise if somoene calls my cellphone, no voicemail.

Any suggestions on a good way to handle this?

I was thinking maybe - have unanswered calls on my cell phone forward to my home phone, and somehow have my home phone then forward the call from my cell phone to my google voice voicemail? (ie if incoming call is from cell phone, forward to google voice)? google voice answers voicemail after no rings, so basically I have it set to now so unanswered calls on my cell go to my google voice.

Any way to do this?


You can have FreePBX route your calls to Google Voicemail but you must be using a new distro, something better or newer than trixbox.

How would it work though with my setup involving also ringing my cellphone? And how do I know if I’m using something better or newer than trixbox? I’m running the lastest (AFAIK) freepbx.


I use confirm calls on my cell phone, that way it never goes to cell phone VM.

Also, don’t be short with our esteemed developers. The latest FreePBX won’t run on an old trixbox system.

trixbox project was shut down over 2 years ago and they stiffed their users. They also traded on the good name of FreePBX. You should know how your system is installed and what versions. This is required info for posting.

Not sure what you mean by being short? Nothing I said was intended to be rude.

My system is FreePBX Asterisk (Ver. 11.6.0).

I thought about requiring a keypress to answer a call, but would like it seamless. But thinking more on it, I guess it’s not possible. The problem being the cell phone forwarding to voicemail. Even if the cell phone redirects, it will still cut the call short :frowning:

So is it posisble to only require a keypress for the cellphone? ie have an incoming call ring my extension AND my cell phone, require a keypress ONLY if the cell phone answers, and if the home phone doesn’t answer after seconds forward to google voice? My only concern is that potentially get voicemails on my cell phone of “To answer this call, please press 1.”…


I have never gotten one of the messages on my cell phone. Even if it is off.

I do have the ring timers pretty tight.

I have used this config for years and to me it is seamless and as good as it is going to get until I can get we can buy SIP accounts tied to a SIM card

Ok, so it looks like the require keypress is ONLY for external calls… good. :slight_smile: So now dumb question, how do I set what to do with an unanswered call? I know I saw it somewhere but can’t recall under what setting? I see under the extension conditions: unavailable, no answer, etc. How do I set it to forward to my google voice?

Thanks again :slight_smile:

Set a miscellaneous destination.

Remember the destination drop boxes are populated as you create destinations

Ok, making progress. Let me know if this sounds right - and need advice on how to change something.

Extension 1
Ringall extension 1 and my cell phone. After 20 seconds unanswered, ring to extension 2. Extension 2 rings google voice # - no keypress required. However - I have my google voice as my outbound route. So - any calls there automatically go to “please enter your password” not please leave a voicemail. When I changed my default outobound route to use flowroute, it works fine. So how do I specify that … if I’m wording this right? extension 2 outbound call uses flowroute instead of the default?


You just need to create an outbound route for your Google voice number and point it to flowroute.

Thanks. I think I’m set. Well, maybe not the optimal configuartion, but here’s what I’ve got.
Extension 1 has a follow me of extension 1 and my cell phone. And a 20 second ‘ring time’ (I’ve noticed BTW the time is off - ie 20 seconds is closer to maybe 10?). So then a outbound route to my google voice # using my flowroute outbound.

So I think that’s working… That leads to is there a way to copy an extension? I had to make a bunch of extension changes, so short of going back and forth at two windows, can I copy the setup from extension 1 to say extension 3?

Thanks again!