Google Voice - No Incoming Calls, Nothing in Logs

How can I confirm that asterisk is INDEED registering properly and set to RECEIVE calls. I’m not having trouble ANSWERING calls, I’m having trouble RECEIVING calls. Outbound calls are WORKING. There’s no evidence of INBOUND calls.

Details in full version…


I’m on day 2 of FreePBX, and I love it, everything was working; then I broke it (or did I??). :frowning:

Downloaded the ISO
Ran 'yum upgrade -y && chkconfig iptables off && reboot’
Setup and logged into FreePBX management interface
Add Google Voice number +Trunk +Outbound (verified it said “Connected”)
Add Extension
Add Incoming Route (+Signaling +2sec Pause)
Apply Config.

On GV, I have Call Presentation off, and Send to Google Talk ON.

Tested GTalk with VOIP client, incoming and outgoing.

HOWEVER, from asterisk, Outbound calls from Extension to World are fine. Incoming calls fail. It’s almost as if the device isn’t registering to receive calls. There’s NOTHING in the logs. When a call comes in, no lines are written to the log file.

This worked yesterday, so I reinstalled, still broken.

In my firewall (Cisco ASA 5505, IOS 9.0.1, inspect SIP) when the VOIP client receives a call, as expected, I get:
6 Dec 10 2012 09:34:47 302013 TEST_CLIENT 58076 GTALK_SERVER 5222 Built outbound TCP connection 8374605 for outside:GTALK_SERVER/5222 (GTALK_SERVER/5222) to inside:TEST_CLIENT/58076 (OUTSIDE_INTERFACE/58076)

There is NO such line indicating that the asterisk server received the message (I would expect the same message pointing to the asterisk server).

One of the things to diagnose is that the asterisk server has to be the ONLY connection to Google Talk, otherwise it won’t work. My cell had logged in. :frowning:

Secondly, my NAT settings were wrong. I don’t know if this is red herring or not. Settings -> Advanced SIP Settings need to be straightened out with “route” and the correct address rather than “yes”.

I just hope someone reading this has their issue solved.

Did you ever figure out what this was? I am having the same problem. I cannot find any other devices that are currently logged into the gtalk account though.

Yes. There will be nothing in the logs because Google will not send the call to you. Cell-phones, Google Talk applications, even signing into Gmail could trigger it. This is EXACTLY why everyone recommends you get a different account for Gtalk, because of how finicky it is.

You can go into your Google Mail and sign out all devices, THEN I recommend you give asterisk a good ol’ restart.

Since I am not a business, I live on the edge and have been restarting asterisk nightly via cron to ensure that gtalk logs in properly. “It Works For Me™.”

Sign up for another account, if that works, then it’s obvious that you have another device signed in.