Google Motif Outbound no Ringback

After updating system, when making outbound calls no ringback is heard. I have Trunk dial option set to r.

Currently on:
Google Voice/Chan Motif
Core 14.0.6

I’ve tried rolling back and using motif on edge track 13.0.4 deleting and adding google voice settings back in between changes with no luck. Calling out is still silent.

A side issue that started happening when ring back tone stopped was when inbound calls come in, i had it set to ring desk phone and external number (cell phone) at the same time. Now the desk phone rings once and calls the cell phone only, but now with no ring back tone.
This last part may be a separate issue.

Go to trunks. Then look for the google voice trunk. Then look at dial options and post what they are here

Asterisk Trunk Dial Options: r
Set to Override

Then it’s already set to and is ringing. This seems like an endpoint issue not a Google Voice or Motif issue. Which is why it’s worked for others and not you.

It was working before and now it doesn’t. I haven’t made any changes to the endpoint. This is happening on two different system.

What should I do to troubleshoot the endpoint issue?


Is “Set to Override” checked or not? If it’s checked then the dial option “r” is already set. Which means “send ringback”.

Yes Override is selected with dial option “r”

I also have a demo trunk that i just added to test, outgoing calls work fine, and when inbound calls come in that require both desk phone and external cell phone to ring they both function fine.

I’m not sure what you are trying to state here. Inbound is not relevant to this conversation is it?

I have an inbound route that goes to my extension. That extension has fm/fm to ring the desk phone and my cell phone. On google it rings the desk phone once and only rings the cell phone without ring back tone. but on the demo trunk im using it rings both my desk phone and my cell phone at the same time with ring back tone.

Found out issue is with google and tmobile…!topic/voice/48CgSY067GA;context-place=forum/voice

Another point to use a real provider. They are so cheap it’s almost a waste of time trying to get Google to work


This needs to be framed!!
Can also be placed on these executives desks who want to “save” money by using Google Voice as a trunk, but pay IT hours to make it work… Then a month later: “URGENT - NO CALLS”
“Sir, have you by any chance changed password on this email?”

Been there done that. GV is not even perfect for a toy project.
Just this week i crashed asterisk with this motif module…

1 Like

I’ve been using Asterisk and FreePBX for quite a while, and I’m at the point where, whenever include “… and I’m using Google Voice…” I just glaze over and stop reading. It was a kludge when it first came out, it’s a violation of Google’s EULA, and it just wastes HUGE amounts of time that you will never get back to save yourself a couple of dollars a month.


I’ve learned a lot from setting up a box at home. I mainly use that number for texting and when i do get a call it calls my cell phone and routes through freepbx for call recording. Other than this one issue it has been extremely stable for me. But as for now I’m using for outbound

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.