Google Cloud VM- no call audio

Latest FreePBX ISO installed on a google cloud instance and setup my trunk, routes and a single extension (x301). The phone registers and the extension can make a call to my cell but when it’s answered there is no audio for the call. I’m trying to determine if the problem is firewall, NAT, or something else. I’m moving from a locally hosted instance to the cloud so there seems to be a bit I’m not understanding. Here is the ‘link’ to the log file if anyone has any suggestions it would be greatly appreciated. I can’t post links as a new user but the ID of my pastbin is pastebinDOTfreepbxDOTorg/view/f9ef4f32

[2022-05-31 16:24:44] NOTICE[2570] res_pjsip_sdp_rtp.c: Disconnecting channel 'PJSIP/301-00000012' for lack of audio RTP activity in 32 seconds

Without the pjsip set logger on output, I don’t think one can improve on your current list of possibilities.

Your log doesn’t include a SIP trace, but here is some general advice:

In Asterisk SIP Settings, confirm that External Address and Local Networks are correctly set. If you change these, after Submit and Apply Config, you must restart Asterisk.

In your VPC firewall rules, confirm that you are forwarding the RTP port range (default is UDP ports 10000-20000) to the PBX.

If you still have trouble, at the Asterisk command prompt type
pjsip set logger on
make a failing test call and paste the resulting log.

I turned pjsip logging on and tried another call. Here is the updated log file


There is something wrong here:

INVITE sip:[email protected]:5060 SIP/2.0
Via: SIP/2.0/UDP;rport;branch=z9hG4bKPj22e3cd28-5444-454f-8095-62ecfbd8ff8f
From: <sip:[email protected]>;tag=b68a83ef-bde1-4c5e-bd53-5007906fbd6b
To: <sip:[email protected]>
Contact: <sip:[email protected]:5060>
Call-ID: f09d403a-f971-4761-a92c-bfc4f88b48ca
CSeq: 22008 INVITE
Supported: 100rel, timer, replaces, norefersub, histinfo
Session-Expires: 1800
Min-SE: 90
Max-Forwards: 70
User-Agent: FPBX-16.0.19(16.25.0)
Content-Type: application/sdp
Content-Length:   333
o=- 124853418 124853418 IN IP4
c=IN IP4

I’d expect the Via and Contact addresses to match the o= and c= ones.

I’m wondering if the latter are over-redacted private, 10/8 addresses, and you haven’t set a proper external media address. Please explain what the addresses in this extract refer to.


It is an overly redacted private address from the inside of my google cloud.

Internal address range:

You need to set the external media address.

Under Settings go to SIP Settings and make sure:

  • External Address is correct
  • Add your Local Networks. Check your region (link below) and add the IP range for your region. Also add any VPN range that you may have.

As @david55 says. But this should be automatic if you have in Asterisk SIP Settings (General tab):
External Address:
Local Networks: / 8

and on the chan_pjsip tab, (udp) section, leave everything blank except Port to Listen On.

Then, after Submit and Apply Config, restart Asterisk.

Could this apply in your case:

Also, look at the generated configuration, in /etc/asterisk/pjsip*.conf, and see what has been generated in terms of media addresses.

david55, stewart, mousa,

I think it was the local network range that was incorrect. I have made the changes suggested and the calls are working now. Thanks so much to all of you!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.