Getting no where attaching zulu to pbxact on internal LAN


(Simont) #1

Hi I have gone thru Zulu+3+Server+Installation and am having problems connecting internal zulu linux client and ios client connects but cannot make any calls other than to itself

Main error appears to be

[2019-11-06 12:45:54] NOTICE[22750]: chan_sip.c:15915 sip_reg_timeout: – Registration for ‘Fm0DPWFNXrPN@trunk2.freepbx.com’ timed out, trying again (Attempt #7)
[2019-11-06 12:45:57] ERROR[22750]: chan_sip.c:4271 __sip_reliable_xmit: Serious Network Trouble; __sip_xmit returns error for pkt data
[2019-11-06 12:45:45] WARNING[22727]: res_pjsip_registrar.c:1093 registrar_on_rx_request: Endpoint ‘anonymous’ has no configured AORs

IOS Zulu whilst connected on the far side of firewall can receive calls from internal pbx numbers
but can not dial back

Linux zulu on internal LAN can not call anyone but receives call ringing

versions PBX 14.0.13.6 and Zulu 14.0.57.5 / Asterick 14.0.1

I note the following in that it is trying to use external ICE servers - not sure if that is correct
November 6th 2019, 1:08:24 pm - info: SessionDescriptionHandler - ICE Servers - [{“urls”:“stun:turn.respoke.io:443”}]
November 6th 2019, 1:08:24 pm - info: SessionDescriptionHandler - Using ICE Servers - [{“urls”:“stun:turn.respoke.io:443”},{“username”:“2-ZnJlZXBieA==-Nzc2NzI1OTE=-YXBpLnNhbmdvbWEuY29t-YzE0OWYyYTMtYzE5OC00NzI3LTlkZjgtNzczY2EwZjI4MWQx.1573128773”,“credential”:“Bf371rts2isAmI99WpjeLhydJ28=”,“urls”:[“turn:an fqdn:443?transport=udp”,“an fqdn:443?transport=tcp”]}]
November 6th 2019, 1:08:24 pm - info: Session b7942fba-c389-4769-ba31-1726554ca4a1 for account 0f27aa22-43ae-4f13-bd9a-21e4aefac208 has been created. Binding to events.
November 6th 2019, 1:08:24 pm - info: Session b7942fba-c389-4769-ba31-1726554ca4a1 for account 0f27aa22-43ae-4f13-bd9a-21e4aefac208 has been destroyed. Unbinding to events.

only other error i can find is
2019-11-06 12:43 +02:00: [2019-11-6 12:43:35.184] [ERROR] console - Error sending mobile waiting call back to dialplan {“message”:"{“message”:“Channel not found”}",“stack”:“Error: {“message”:“Channel not found”}\n at SwaggerRequest.swaggerError [as errorCallback] (/var/www/html/admin/modules/zulu/node/node_modules/ari-client/lib/client.js:246:23)\n at Object.error (/var/www/html/admin/modules/zulu/node/node_modules/ari-client/node_modules/swagger-client/lib/swagger.js:1077:24)\n at EventEmitter.error (/var/www/html/admin/modules/zulu/node/node_modules/ari-client/node_modules/swagger-client/lib/swagger.js:1296:19)\n at emitOne (events.js:116:13)\n at EventEmitter.emit (events.js:211:7)\n at emit (/var/www/html/admin/modules/zulu/node/node_modules/ari-client/node_modules/swagger-client/node_modules/shred/lib/shred/request.js:454:21)\n at /var/www/html/admin/modules/zulu/node/node_modules/ari-client/node_modules/swagger-client/node_modules/shred/lib/shred/request.js:473:9\n at setBodyAndFinish (/var/www/html/admin/modules/zulu/node/node_modules/ari-client/node_modules/swagger-client/node_modules/shred/lib/shred/response.js:103:7)\n at IncomingMessage. (/var/www/html/admin/modules/zulu/node/node_modules/ari-client/node_modules/swagger-client/node_modules/shred/lib/shred/response.js:120:7)\n at emitNone (events.js:111:20)\n at IncomingMessage.emit (events.js:208:7)\n at endReadableNT (_stream_readable.js:1064:12)\n at _combinedTickCallback (internal/process/next_tick.js:138:11)\n at process._tickDomainCallback (internal/process/next_tick.js:218:9)”,“isOperational”:true,"__error_callsites":[{},{},{},{},{},{},{},{},{},{},{},{},{},{}]}

Sorry I am a bit new to this so probably made some fundemental mistake somewhere

any help appreciated


(Simont) #2

So the world has moved on, and now my onl;y problem is connecting the Zulu v3 softphone linux client
IOS and Windows works fine!
Within the Linux client under preferences I dont see entries for Audio which suggests something isnt quite right
I am running Ubuntu 18 bionic
Any clues anyone???


(system) closed #3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.