Getting Anveo Direct Outbound Calling to work with FreePBX

I recently ported my number to Anveo Direct and have successfully configured inbound calling. However, I can’t get outbound calling to work. When we try to place a call out, our Obi1062 phone says “Trying” while the destination phone we are calling to rings. If we answer, the desk phone still says “Trying” and eventually fails, while the cell phone hangs up after about 35 seconds of call time.

Here is my first Trunk (SIP) Configuration

Outgoing Peer Details:

Incoming User Context: AnveoDirectInbound
Incoming User Details:

I have a second trunk (custom) for outbound tied to my only outbound route. It uses the sip string “SIP/[email protected]” where the 012345 is my prefix password set from the Anveo website.

SIP Trace sometimes reveals a “481 Call leg/transaction does not exist” message, but sometimes I can’t find anything in the error logs. Obviously the call is connecting but RTP is never established. Could it be a codec issue? I’m very puzzled as to what the issue is. Let me know if you want to see Asterisk logs. Any help would be greatly appreciated, as I am stuck calling out of a Google Voice trunk I set up temporarily until this is fixed.

I turned on debugging in Asterisk and got the following log when I tried to place an outbound call to my cell phone. My desk phone is 18, the PBX Server is 20, and my phone number and public ip were redacted for obvious reasons. The desk phone is extension 5 in the logs.

View Log: https:// drive . google . com/file/d/1qRVu7zXbaxvtnBI01LZHsrQj8u3lQnQu/view?usp=sharing

Are you using this as a shorthand for your Incoming Trunk and you actually have five inbound trunks, or are you actually using five entries of each of these in the one inbound trunk?

The reason I ask is we were helping a guy with a similar problem and the “host” line with five entries didn’t work right. He had to set up four inbound trunks (one per trunk).

I have one trunk with all five peer settings for inbound. In addition, I have one outbound custom trunk using the sip string. If it’s worth mentioning, inbound calling just stopped working as well even though no configuration changes were made.

That was his symptom as well.

I tried setting up five separate trunks with the same outbound settings for each and inbound settings for each individual ip (five total). Inbound calling is still failing. I’m not in the office so I can’t test outbound.

Just so we’re clear.

You set up five “friend” trunks that serve your inbound and outbound calling for the 5 servers you can connect to. A “friend” trunk is a combination of an inbound (user) trunk and an outbound (peer) trunk.

Outbound calling depends on several factors to work, but they all revolve around what the remote system is expecting in terms of authentication. If Anveo uses IP Authentication (for example), then each of the connections will be set up with an IP address as the destination and your external IP address as the source.

Another factor that might be figuring into this is that not all outbound servers will work as inbound servers from your provider. Many providers use different servers for their inbound and outbound calling service. So, for example, if your first outbound trunk (in your outbound route) doesn’t allow you to connect to the remote server, your calls could fail (based on settings).

At this point, rather than blindly trying to troubleshoot a problem, we’re going to need to see the log from /var/log/asterisk/full for a failed outbound call.

With inbound calling now failing, there could be many places that are causing problems. You might want to call Anveo’s technical support and see what they are seeing on an inbound call. The error mode they are seeing could help troubleshoot this much more quickly than making suggestions and you telling us “Nope, try again”, which I feel like is where we are at now.

I disabled IPv4 Firewall Protection and SIP ALG from my router and restored outbound and inbound calling successfully.

Disabling that goes a long way to getting this stuff working. It’s great for extensions (that’s a lie, it’s actually almost always terrible. :slight_smile: ) but it will eventually kill your PBX operations.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.