FreePBX | Register | Issues | Wiki | Portal | Support

Get .Net Core default page after installing FreePBX 14 on Microsoft Azure Centos 7 VM

freepbx
Tags: #<Tag:0x00007fd2e934d618>

(John Yost) #1

I provisioned a Microsoft Azrue Centos 7 with .Net Core 2 and went through the FreePBX manual installation guide found here: https://wiki.freepbx.org/display/FOP/Installing+FreePBX+14+on+CentOS+7

Everything went perfectly with no issues.

When I finished the installation and opened a browser to the GUI, I can only get the .Net Core default web page like this one: https://msdnshared.blob.core.windows.net/media/2016/06/firstWebApp.png

Does anyone know why I’m getting this page and not the FreePBX GUI?

Thanks in advance,
John

Update: I disabled the default dotnetd.service which was responsible for the default .net core page. But, now I get a page that says “Service Unavailable, The server is temporarily unable to service…” which I think means the apache web server is not configured correctly to serve up the gui webroot. Still digging…

Update: I deleted the VM and started a new VM from an image WITHOUT .Net Core. That image worked perfectly and FreePBX is up and running now.

Solved!


#2

Hey @jyost
Wondering how FreePBX has been working for you in Azure? Looking to set something similar up but the lack of official support and not being able to run Commercial Modules (like Endpoint Manager) is freaking us out a bit.