Genalertglyphicon


#1

Hi,
After updating my freepbx I now get an issue on the dashboard. The text says " Unable to locate the freepbx BMO Class ““Genalertglyphicon”” a requested module might be disabled or uninstalled". Has this been deprecated or is this an actual error.

Thanks,

Phil


Unable to locate the FreePBX BMO Class Genalertglyphicon'
(Collis Michael) #2

[merged to existing thread - mod]

Hi all,

After an power outage today there has seems to be a few issues when logging into freepbx We get the following error message
Unable to locate the FreePBX BMO Class ‘Genalertglyphicon’ A required module might be disabled or uninstalled. Recommended steps (run from the CLI): 1) fwconsole ma install genalertglyphicon 2) fwconsole ma enable genalertglyphicon
File:/var/www/html/admin/libraries/BMO/Self_Helper.class.php:212

I have tried running the following command
fwconsole ma downloadinstall genalertglyphicon --edge
But i get the following error The following error(s) occured:

  • Retrieved Module XML Was Empty
    I have also tried running the following command fwconsole ma install genalertglyphicon but i receive the error command now found.

I am unsure on where to go from here

Can anyone help

Thanks


(Lorne Gaetz) #3

Unable to reproduce. What is output of:

fwconsole ma list | pastebin

#4

Do you see any disabled module if you go to Admin=>Module Admin ?


(Kapil Gupta) #5

Please see if dashboard uninstall/install can help here.
Freepbx ssh shell -
fwconsole ma uninstall dashboard
fwconsole ma install dashboard

or do it from Admin=>Module Admin

thanks.


(Steve L) #6

Hi, I am experiencing this too.

Pastebin output:
https://pastebin.freepbx.org/view/39201630

Modules that are not showing enabled:
| motif | | Not Installed (Locally available) | GPLv3+ |
sng_mcu | 13.0.5 | Disabled | Commercial


(Steve L) #7

Dashboard uninstall/install via the command line did not appear to change anything.


(Kapil Gupta) #8

Hi @stevedl could you please paste complete whoops error output or screenshot. thanks.


(Steve L) #9

Is this what you required?


(Sandesh Prakash) #10

Hi @philcunliffe @stevedl @MCollis11

The issue was due to the iotserver module, iotserver module is still in beta phase so request you please uninstall the same through the GUI using module admin or through CLI using the below mentioned steps and your issue will be resolved.

fwconsole ma uninstall iotserver
fwconsole ma remove iotserver
fwconsole r

Thanks you.


(Collis Michael) #11

Hi @psandesh

That resolved my issues!! Thank you very much

Regards,


#13

Hi …thats brilliant. Thanks. Fixed my issue on the dashboard.:grinning:


(Itzik) #14

What is this new module about?


(Lorne Gaetz) #15

https://wiki.freepbx.org/display/SMAR


(Steve L) #16

Thank you. I uninstalled and removed iotserver using the Module Admin interface and the dashboard is working again. :slight_smile:


(system) closed #17

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.