FXS Port Cisco

I am just about to pull my hair out. I can’t figure out how to get this to work. I have a Cisco 1760 Router with a FXS Card it for analog phones. I can send and Receive calls just fine, in and out of local network. However I cannot seem to get Call waiting to work or even 3 way calling. When I click flash on my phone it just blinks and goes back to the current call. As for call waiting, when someone tries to call that extension or call the main number it never gets the Call Waiting beep anything at all. Before you ask yes call Waiting is turned on!

It is acting like only one channel is allowed to a SIP connection. FYI the Cisco 1760 is connected by SIP and registered like a normal SIP extension.

Any help would be appreciated.

I dont know if the problem is with FreePBX or the Cisco Config on the SIP side. I dont know if the Cisco needs multiple lines to the FreePBX or if something is wrong with my configuration of FreePBX. My IP phones work right, Call waiting, multiple line etc.

Also tomorrow I will try to post the Astrisk logs, But when you are in a call it basically says its busy… Thanks for any help…

You need to do some debugs. On the Cisco ‘debug ccsip calls’ don’t forget to term mon if you are telnet’d in.

Also you may have to mess with the timing, from IOS 12.4 manual:

Modifying Hookflash

To change the upper limit of the hookflash duration range for an analog FXS port, perform the following steps.

  1. enable

  2. configure terminal

  3. voice-port port-number

  4. timing hookflash-input milliseconds

  5. end


Command or Action
Step 1
Router> enable
Enables privileged EXEC mode.
•Enter your password if prompted.

Step 2
configure terminal
Router# configure terminal
Enters global configuration mode.
Step 3
voice-port slot-number/port-number
voice-port slot-number/subunit-number/port
Router(config)# voice-port 2/1
Enters voice-port configuration mode.
•Format and values for analog FXS voice port number is platform-dependent. Type ? for values.

Step 4
timing hookflash-input milliseconds
Router(config-voiceport)# timing hookflash-input 175
Specifies the maximum duration of an on-hook condition that will be interpreted as a hookflash.
•milliseconds—Range: 50 to 1550. Default: 1000.

Step 5
Router(config-voiceport)# end
Exits voice-port configuration mode and returns to privileged EXEC mode.
Configuring PLAR with DTMF Out-Pulse Digits

Thank you SkykingOH that worked for the flash, now I get a new line, but instead it just hangs up the old line! I had tried Hookflash before but I guess I had it too long and that was the problem. I tried the 175 that you suggested and it worked.

But now it hangs up the old line instead of putting it on hold, and it still will accept call waiting. I think if I get the 3 way fixed, it will fix all my problems. I really apricate the help.

Homework: http://www.cisco.com/en/US/docs/ios/voice/sip/configuration/guide/sip_cg-hookflash_ps6350_TSD_Products_Configuration_Guide_Chapter.html

Actually I have been reading that all day, I cant figure out why my 1760 dosnt have the dsapp command, however in on the documentation it says its supported. Ill get back to people when I figure this out… Thanks Skyking for your help.

Fixed and working! Thanks for all the help, heck sometimes you just need someone to say hey check this out… and it jogs something in your memory. I cant thank you enough…