FXS modules not being recognized

Hi all

I’m having a tough time doing a migration and could really use some help.

I upgraded my server from pci based to pci-E based so I bought a new A4B card to replace my old TDM card.

I purchased the card brand new from an eBay vendor named Flytechcomputersinc that had a good reputation in his feedback.

All of the modules worked fine in the TDM card for years.

I put them in the A4B card and fire up the server with a fresh install of FreePBX and when it’s all installed there is no recognition of the green FXS boards.

I run /etc/init.d/dahdi status and it replies that there is an FXO card in channel 1 but the other three are ‘unknown’

I tried moving the red fxo card from channel to channel and it appeared on all four channels but it won’t see the FXS modules in the same positions.

I put the green FXS modules back in the old server and they show up and work just fine.

I’m kind of stumped… the only other change I can think of is that I went from an X86 version to an X64 version of the disto. I don’t see how that would affect things but you never know right?

Does anyone have any pearls of wisdom? I thought new modules were supposed to be recognized on a reboot and just show up. I don’t remember having to write config files the last two times I loaded FreePBX.


I loaded the i386 disto and got the same results so it has nothing to do with the x64 disto.


I tried the card in a completely different computer with the same results, so it’s not the computer.


I just called Digium tech support and they think I’ve got a bad card.


Really old Digium FXS modules won’t work in the new PCI-E cards.

They work in the older PCI cards (TDMXXXX) but not the newer A4B cards.

This is confirmed with Digium Tech support, they sent out a new A4B card and the problem persisted and finally after I sent a picture of the modules they tracked down the serial numbers confirmed that they were genuine Digium FXS modules but that they were so old they wouldn’t work in the new architecture.

So the next time you catch yourself thinking that all FXS modules are the same think of this thread.


1 Like

As far as I’m concerned, this is a problem that Digium should have never caused.

When the architecture of a module changes this significantly, the card should have either never accepted the modules (by changing the plug configuration) or identified that these modules would not work (something on the system logs that tells you the modules were nerfed).

Glad to hear that you got it figured out and even more glad that you posted your finding here.