Fwconsole reload error message

I get this error message on fwconsole reload. Tried reinstall the respapps , yet have same error message. Any fix for that? Apply config from webgui works.

In Restapps.class.php line 1429:

[Whoops\Exception\ErrorException (2)]
Invalid argument supplied for foreach()

Exception trace:
() at /var/www/html/admin/modules/restapps/Restapps.class.php:1429
Whoops\Run->handleError() at /var/www/html/admin/modules/restapps/Restapps.class.php:1429
FreePBX\modules\Restapps->parseQueues() at /var/www/html/admin/modules/restapps/Restapps.class.php:1704
FreePBX\modules\Restapps->doDialplanHook() at /var/www/html/admin/libraries/BMO/DialplanHooks.class.php:107
FreePBX\DialplanHooks->processHooks() at /var/www/html/admin/libraries/Console/Reload.class.php:318
FreePBX\Console\Command\Reload->reload() at /var/www/html/admin/libraries/Console/Reload.class.php:91
FreePBX\Console\Command\Reload->execute() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Command/Command.php:255
Symfony\Component\Console\Command\Command->run() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php:960
Symfony\Component\Console\Application->doRunCommand() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php:255
Symfony\Component\Console\Application->doRun() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php:148
Symfony\Component\Console\Application->run() at /var/lib/asterisk/bin/fwconsole:163

reload [–json] [–dry-run] [–skip-registry-checks] [–dont-reload-asterisk]

Any suggestion?

what did you run to try and reinstall restapps?

fwconsole ma downloadinstall restapps

Or if you aren’t using it (be certain) or Endpoint Manager you can remove it

fwconsole ma delete restapps

I tried both, removed restapps , reinstalled it , had same error message.
Then I deleted restapps since I am not using it , the error changed to something similar , but for queue .php with same error as below
[Whoops\Exception\ErrorException (2)]
Invalid argument supplied for foreach()

I am wondering if this is related to the php but the version of php is same as another server that has not this issue

Provide details of your install. Distro or OSS install, FreePBX version, etc.

If this doesnt work put a --force at the end.

with --force at the end , I have got same error message after reload

In Restapps.class.php line 1429:

[Whoops\Exception\ErrorException (2)]
Invalid argument supplied for foreach()

Its distro , FreePBX 15.0.37.4 , asterisk version 16.24.1
I do not use RESTAPI, but like I said with RESTAPI uninstalled, I get same error message with this file : In queue_conf.php line 181:

And I have queue pro module. I tried upgrade all also.

If you are not using it,

fwconsole ma delete restapps