Fwconsole : Permission denied


Did the manual update 10.13.66-7 from 10.13.66-6. Got a lot of Permission denied running it. I also did a module upgrade (framework) but can’t apply the config.

exit: 126
sh: /var/lib/asterisk/bin/retrieve_conf: Permission denied

Tried to run fwconsole chown but getting

bash: /usr/local/sbin/fwconsole: Permission denied

Haven’t reboot my server yet. It is working (asterisk and calls).

What to do?


Are you logged in as root? You might try ‘sudo fwconsole chown’ and see what happens.

Yep, tried, same error!


with chmod 777 /usr/sbin/fwconsole I was able to make fwconsole work again.

Then, did a fwconsole chown


Reapplied the upgrade.

Seems to work now!!!

I’m having the same issue!

Did you just enter “fwconsole chown” without specifying the new owner?


Only fwconsole chown (it’s a command that knows what permission all folders and files needs and set them)

We just upgraded (via the system admin module - have always used CLI before) from 10.13.66-6 to 10.13.66-7. We are now experiencing almost the exact same issues described above. We can run fwconsole chown and it shows success with no errors but attempting to get into the commercial endpoint manager gives us the error message copied below. Did try to chmod the fwconsole directory, fwconsole chown, reboot, re-applied 66-7 as mentioned above but still have same errors. Any ideas? Everything was good until the 66-6 to 66-7 upgrade attempt from the system admin module. What other info do you need from me?




Can not write to the LESS cache folder at /var/www/html/admin/modules/endpoint/assets/less/cache. Please run (from the CLI): fwconsole chown

Trace Back
/var/www/html/admin/libraries/BMO/Less.class.php:189 die_freepbx()
[0]: Can not write to the LESS cache folder at /var/www/html/admin/modules/endpoint/assets/less/cache. Please run (from the CLI): fwconsole chown

/var/www/html/admin/libraries/BMO/Less.class.php:96 FreePBX\Less->getCachedFile()
[0]: /var/www/html/admin/modules/endpoint/assets/less
[1]: /admin/assets/endpoint

/var/www/html/admin/libraries/view.functions.php:399 FreePBX\Less->generateModuleStyles()
[0]: endpoint
[1]: endpoint

/var/www/html/admin/config.php:661 framework_include_css()

To (hopefully) add a little more clarity - we have the exact same issue as stated in the original post - retrieve_conf issue. But, unlike the OP we didn’t have any errors running fwconsole chown. Even so, the problem obviously did not go away.

Thanks again for any ideas.


Upgrade to the latest framework which will fix this issue

then run: fwconsole chown

Thanks for the reply, Andrew. It will not update through the Module Administration module. Here is a screenshot. Is there a command to try it through the CLI?

Please run these commands from the cli

fwconsole chown --full
fwconsole ma upgrade framework
1 Like

fwconsole chown --full ran with no problems
fwconsole upgrade framework throws the following error-

You could have easily figured out that I mistyped the command by running fwconsole. Anyways. Revised commands below:

fwconsole chown --full
fwconsole ma upgrade framework

You’re obviously giving me too much credit :smile:
Thanks again, Andrew! I did actually find “modadmin” (didn’t put 2x2 together and realize it was ma). Tried that before you replied and got a similar error.

BUT, running it as “ma” instead worked! Thanks for the replies and your patience, Andrew!


Running fwconsole will give you a list of supported commands. modadmin isn’t one (though Im sure it’s in the wiki incorrectly). “moduleadmin” is however a valid option. I need to go update the wiki obviously.

20 posts were split to a new topic: Fwconsole not found

A post was merged into an existing topic: Fwconsole not found

This thread saved me at the tail end of a 6 to 10 upgrade tonight. I had to chmod fwconsole to 777 to get access to it to fix all the other permission issues. Still have issues with index.php and schmooze-logo.png missing, though.

Dear All,

the Quick solution to the permission issue is just follow following steps:

  1. fwconsole chown
  2. fwconsole reload

this is for the new Asterisk version and for old version you have to use “amportal” instead of “fwconsole”