Ftp server ports on FreePBX 'VoIP Server'

Hi guys. A little background: Good friend passed away. He had setup a FreePBX ‘VoIP Server’ for his small business but didn’t leave behind passwords for accessing the box. I was able to find the web Admin password by finding a backup file and examining it, and also was able to change the root password using instructions posted here (thanks!).

His partner is bringing-on a new guy to handle my friend’s workload, and asked if I could take one of the friend’s remote phones (a Yealink T48G) and set it up.

I tried booting the phone at home, it can’t connect (no service).

It is using ftp to configure. So I tried to ftp into the FreePBX server to get the configuration, but was given a “200 PORT command successful. Consider using PASV.” message, and then nothing.

So I imagine there is a range of ports I need to open on the router to accommodate the ftp server, I just don’t know the default range. Obviously 21 is open, but I think that is it.

So I looked in the ftp area of the FreePBX admin page and all I can do is enable/disable, and set passwords.

Is there a default set or ports used by FreePBX?

Thanks in advance.

you also need to add the helpers in iptables - my guess is that the system you are running does not do that automatically for you.

Thank you for your help!

So it turns out he has two internet connections (AT&T and Time Warner) going into an Untangle UTM (router). He added the AT&T circuit because he was having such difficulty getting Time Warner to carry voice reliably.

And when he added the AT&T, he set a route on the Untangle so the FreePBX would always use the AT&T circuit.

BUT, he didn’t update port forwarding.

So the phone was set to get its configuration via the Time Warner WAN address. But the FreePBX box was communicating via the AT&T circuit.

So I changed the port forwarding on the Untangle, no I need to change the IP on the phone and see if it gets the configuration.

I think I’m probably just in for another problem, I’m betting the configuration is messed up on the Endpoint Manager, but we will see.

Again, thanks for helping me. Sometimes it is difficult enough to diagnose my own FreePBX stuff with single WAN connections. Troubleshooting someone else’s with two WAN connections is a little different.

1 Like