FrrePBX GUI not working - ERR_CONNECTION_REFUSED

Good day,

Upgraded from FreePBX 11 to 12 and worked fine. Started doing updates and locked up. Trying to get back into FreePBX GUI throws out the ERR_CONNECTION_REFUSED.

I still have SSH access to AsteriskNOW. Found the following:

Error(s) have occured, the following is the retrieve_conf output:
exit: 255
PHP Fatal error: Uncaught exception ‘PDOException’ with message ‘SQLSTATE[HY000]: General error: 126 Incorrect key file for table ‘./asterisk/kvstore.MYI’; try to repair it’ in /var/www/html/admin/libraries/BMO/DB_Helper.class.php:213
Stack trace:

0 /var/www/html/admin/libraries/BMO/DB_Helper.class.php(213): PDOStatement->execute(Array) #1 /var/www/html/admin/libraries/BMO/Hooks.class.php(102): DB_Helper->setConfig(‘hooks’, Array) #2 /var/lib/asterisk/bin/retrieve_conf(26): Hooks->updateBMOHooks() #3 {main}

thrown in /var/www/html/admin/libraries/BMO/DB_Helper.class.php on line 213

Just to add to the above, Distro version 6.12.65-26

Trying to restore the framework I get the following failures:

Shutting down REST applications daemon: [FAILED]
Shutting down Queue callback daemon: [FAILED]
Stopping prosody: Stopped [ OK ]
Shutting down XMPP Presence State daemon: [FAILED]

That’s the error. It’s asking you to repair the kvstore database, as it’s corrupt. You can fix that simply by:

mysqlcheck -r asterisk

2 Likes

you might just want to run:

mysqlcheck --auto-repair --all-databases

That will check and repair all databases.

2 Likes

Thank you very much for the advice Rob and Dave, it is much appreciated.

The databases have been repaired, but I still can not seem to get the FreePBX GUI to display. I’m guessing that there might be some issue with the PHP side as well.

Are you receiving the same error?

You might want to check /etc/httpd/conf.d/schmoozecom.conf and make sure you did not get anything stepped on (I’ve had this happen when updating). There are also a couple other conf files there to take a look at.

Dave,

Yes, I am still unable to log into the FreePBX GUI with the browser still returning the same response ERR_CONNECTION_REFUSED.

I tried ‘/etc/httpd/conf.d/schmoozecom.conf’ but received the following:
’-bash: /etc/httpd/conf.d/schmoozecom.conf: Permission denied’

Use:

cat /etc/httpd/conf.d/schmoozecom.conf

to see the contents of the file. Note that if you try to post it here, the forum will get confused with the < and > signs, and not display it properly. You’ll need to put it somewhere like http://pastebin.ca

Hi Rob,

Herewith the pastebin link for the output: http://pastebin.ca/2980408

That’s missing a closing tag on the bottom line… but apart from that, it looks fine. (I’m assuming it was a copy and paste error)

Hi Rob,

The only other output after the ones that I placed in pastebin was (replacing the < and > with |)

|/virtualhost|[[email protected]70 ~]#

Not sure if this is what your were referring to Rob.

Is there anything else that you could recommend that I look at to try and get the GUI back up and running?

Herewith the latest debug info:

==> /var/log/asterisk/freepbx.log <==
ucp 12.0.22 (current: 12.0.17)
voicemail 12.0.36 (current: 12.0.35)
)
[2015-Apr-27 11:28:58] [INFO] (bin/module_admin:762) - No such repo: [disable], skipping
[2015-Apr-27 11:29:34] [WARNING] (libraries/modulefunctions.legacy.php:7) - Depreciated Function module_getinfo detected in /var/www/html/admin/modules/bria/functions.inc/userman_hooks.php on line 15
[2015-Apr-27 11:29:34] [PHP-WARNING] (/var/www/html/admin/modules/cxpanel/brand.php:3) - file_get_contents(/etc/schmooze/operator-panel-brand): failed to open stream: No such file or directory
[2015-Apr-27 11:36:26] [INFO] (bin/freepbx_setting:42) - trying to run as user asterisk:
[2015-Apr-27 11:36:26] [INFO] (bin/freepbx_setting:43) -
[2015-Apr-27 11:36:27] [INFO] (bin/freepbx_setting:79) - [FPBXDBUGDISABLE] changed from previous value: [1] to new value: [0]
[2015-Apr-27 11:36:27] [INFO] (bin/freepbx_setting:80) -

I’m guessing that the “PHP-WARNING” might be the issue here.

OK, if it’s still down - are you sure apache is running? (‘service httpd start’)?

It’s seems that it’s not, herewith the info returned for (‘service httpd start’):

Starting httpd: Warning: DocumentRoot [/var/www/html/aastra/] does not exist
Syntax error on line 105 of /etc/httpd/conf.d/ssl.conf:
SSLCertificateFile: file ‘/etc/pki/tls/certs/localhost.crt’ does not exist or is empty
[FAILED]

Just delete that ssl.conf file, and it should be fine.

rm -f /etc/httpd/conf.d/ssl.conf</code.>

Rob, you are a Rock Star! :sunglasses:

Thank you very much for all the help. GUI is up and running :slight_smile:

1 Like