Fresh v.16 Install And Issues With Fail2Ban Starting (Zulu?)

Have been running v.15 without any paid licenses in a home/testing environment and do not use the built in firewall. After backing up v.15, I installed v.16 from iso to USB. Install through default install suggestions left me with no video output early on, but waited two hours with no good install. Rebooted and selected fully automated and I appear to have a successful installation. I restored from v.15 backup right away, but notice that the dashboard is telling me about the OpenVPN Security issue and I see that Fail2Ban is not running. The OpenVPN error offers to resolve the issue, but leads me to the System Admin page, but I have no options for OpenVPN.

I can get Fail2Ban to start only by editing jail.local and commenting out the Zulu portion of it. If I reboot, Fail2Ban fails to start until I edit jail.local again and restart Fail2Ban.

I’m not sure I care about OpenVPN issue first off, but would like to take care of Fail2Ban running without editing a file each time the PBX reboots.

I have noticed other posts here mentioning issues along these lines, but I am not seeing what my problem is.

What did I do wrong or how can I take care of this (other than going back to v.15)?

Thanks.

OpenVPN config via GUI is only available with SysAdmin Pro. If you’re not using OpenVPN then you don’t need to worry about it.

Are you using Zulu? If not you could try disabling it (you might need to disable SangomaCRM first) see if that fixes the issue. I assume you have done all Module/Yum updates to get everything as up to date as possible?

Thanks Richard. I am not using Zulu and forgot to mention that I disabled it without relief. Yes, I have ran yum updates and checked for latest modules.

quick fix, make jail.local ‘immutable’ chattr +i /etc/fail2ban/jail.local after getting it the way you want.

Thanks Dicko. chattr seems to have taken care of it for me. I didn’t even know of the chattr command before! I’ll have to remember that. It looks like a ls or ll doesn’t hint at the chattr status of a file, but lsattr does. I probably won’t remember that starting tomorrow, so I better bookmark this thread :wink:

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.