Freepbx17 issues: admin gui error

hi,
i am running freepbx17 latest version for some weeks now at home, it worked fine, but sometimes i had issues which were resolved next day y the next update.
now i have for some days the following logs every 5s:

==> /var/log/auth.log <==
2024-03-22T21:37:37.813926+01:00 freepbx runuser: pam_unix(runuser:session): session closed for user asterisk
2024-03-22T21:37:42.820443+01:00 freepbx runuser: pam_unix(runuser:session): session opened for user asterisk(uid=999) by (uid=0)
2024-03-22T21:37:42.821734+01:00 freepbx nologin: Attempted login by UNKNOWN (UID: 999) on UNKNOWN
2024-03-22T21:37:42.821845+01:00 freepbx runuser: pam_unix(runuser:session): session closed for user asterisk

==> /var/log/syslog <==
2024-03-22T21:37:42.822897+01:00 freepbx php: Unparseable output from getservices - ["This account is currently not available."] - returned 1
2024-03-22T21:37:42.823021+01:00 freepbx php: Unable to see safemode in services.. Sleeping 5 seconds and retrying

what is causing this logins? how can i fix it.
i installed freepbx17 on lxc debian 12 with this script:

any ideas?
regards.4andre

looking at it briefly - safemode and getservices make me think its related to the firewall module in the second example

take a look at the status overview page within firewall … does it display coherent data ?

— unsure of the first example but it has triggered to take a closer look at those logs

i did review my own logs and i dont see anything similar … if you havent installed the system using the very latest script version i would try rebuilding (and if you werent already , download the script file to the system and execute it locally , dont use CURL at this time as we saw the script failing with no visible indication it was doing so - im also using all the latest apt updates and upgrades … 12.5

great, when stopping the firewall the messages disappear immediately. thanks. i will investigate further.
regards,
andre

ok, as soon as i disable the firewall the messages disappear. disabling sip protocol (pjsip) doesn’t change anything here.

i dont see the behavior on my test system

can you check to see if this still occurs when you install on a standard debian image … we have no testing targeted at LXC , if its unique to LXC the recommendation would be not to use it at this time and open an issue at FreePBX · GitHub ( look for the pinned issue tracker

The design of the Freepbx firewall isn’t very forgiving for virtual environments that may use alternative ethernet interfaces. Perhaps Sangoma can look into improving this at some point.

it is very easy to change the interface name to eth0, google for 70-persistent-net.rule

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.