FreePBX14 Slow saving extension

Hi everybody,

Asterisk: 14.7.4
CPU: 4 vCore Intel Xeon E5-2620 v4 @ 2.10Ghz
Memory: 21GB
HD: SAS disk

When I create a new extension and press save, the GUIi take mora than 15 minute to save it. The GUI keep loading.

I enable in advanced settings and turn on Performance Logging and then type: fwconsole dbug to see where it’s taking so long.

Below the highest time process:

[type] => PERF
[str] => processHooks-Xmpp::usermanAddContactInfo_start
[now] => 1660171961.287731
[timediff] => 60.583329
[mem] => 12.342224 MB
[memdiff] => -3.039063 KB
[file] => /var/www/html/admin/modules/userman/Userman.class.php:1240

[type] => PERF
[str] => processHooks-Webrtc::dashboardIgnoreExt_start
[now] => 1660259289.007149
[timediff] => 6.829010
[mem] => 16.460381 MB
[memdiff] => 8.814453 MB
[file] => /var/www/html/admin/modules/dashboard/Dashboard.class.php:358

How can I fix this?

Hi @hunteralberto
Check your FreePBX box DNS settings and if you doesn’t have Public DNS ( / / ) add as 2nd and 3rd additional DNS.

After apply Public DNS run below command to refresh your PBX ZendID and Update Modules

fwconsole sa u
fwconsole ma --refreshsignatures
fwconsole ma upgradeall
time fwconsole r --verbose

That doesn’t sound right. If is a valid server, you shouldn’t need any other, as it should be very unlikely for it to fail independently of the machine as a whole, and it should either be configured to forward to public/ISP server, or be configured to use the root servers to locate authoritative servers for the target domain.

Also, typical default Linux installations don’t enable a local DNS server. I’d have to guess that the Sangoma one does, if this screenshot is the recommendation for FreePBX, but you may well find out that there is no server running on, in which case you will have to wait for all requests to time out before going to an external one. (Although, for a request to, you should really get a fast, port unreachable, unless you have very aggressive firewwalling that suppresses ICMP Unreachable, even on the loop back interface.)

As should be obvious, this is OS related, but that was not mentioned in the configuration.

Yep, that is the recommended config. I think it’s because when a reload happens it checks back to licensing or something.

Whilst it doesn’t stop the reload it has to wait for the timeout for reaching Sangoma’s servers if there is no external DNS set.

Whilst I don’t fully understand or agree with the logic of this, it’s the way it’s been for a long time.

I’ve also seen it the other way where is only has external DNS entries and adding speeds up the reload time.

How many users/extensions on this system?


616 extension.

Do you see a noticeable difference when you create an extension but do not create an associated user with it?

Wow, I disable “Link to a Default User” and it work as a charm!!!

There’s a way to set “Link to a Default User” to “none” as default?



Very nice tip!

1 Like

Ah: cool point.

Irresponsibly my system was not active, right now I’m trying to activate it so I can manage the DNS. I’m having a issue but when I press Active but I found something in other thread about this. I will update when I figure out this.

Hi @lgaetz

I Follow the DNS step, but get the same time saving new extension. The only way is selecting don’t create/associated user during the creation.

Any other idea?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.