FreePBX | Register | Issues | Wiki | Portal | Support

FreePBX14 Raid Install Problems


(Mvogel4949) #1

I’m attempting to make a server with dual HD (software raid) from the newest FreePBX14 distro. I’ve used this distro in the past and it always seems to set up the raid correctly. In the BIOS both HD are seen. After running the distro install though it seems that raid is not set up. I used the standard automatic distro setup which I believe includes raid.

image


(Mvogel4949) #2

image

It’s almost as if it’s treating the 2 HD as a single HD instead of having mirror images of themselves


#3

I have experienced the same issue, where one disk is used for /boot and the other is used for the SagomaVG volume group. I created a bug report but so far no news.


(Mvogel4949) #4

I’m thinking my only option is to install to a single HD and then follow the sangoma guide to setup raid after the fact. The guide was written in 2013 so I’m hoping it is still applicable to FreePBX14

https://wiki.freepbx.org/display/PPS/How+to+Setup+Software+Raid+after+the+fact


(Mvogel4949) #5

Do you think I could use this guide in FreePBX14? I found your bug ticket and it appears to be in progress.

https://wiki.freepbx.org/display/PPS/How+to+Setup+Software+Raid+after+the+fact


#6

Unfortunately that guide is not applicable anymore. But there are a lot of guides on the internet for CentOS 7.
In fact I tried one, I installed to a single disk but without LVM, because it is a little more difficult, and then I migrated to an mdraid RAID 1.
Another way to do it semi-automarically is to choose custom installation and custom partitioning and create the mdraid RAID 1 manually during the installation.


(Mvogel4949) #8

I tried using the advanced install with this guide:

Danilo Dellaquila

CentOS 7 Server Installation with RAID

This tutorial shows how to install a basic CentOS 7 server with mirrored disks (RAID 1)

but ended up with:

not ideal


#9

Use the distro installer and select custom install. Then create 3 RAID1 partitions:
/
/boot
swap

Depending on the size of your installation in terms of extensions and call load, / should be OK with 100gb, /boot should be OK with 5gb and swap should be OK being the same size as your total RAM.

If you are using UEFI, I think you also need to create a partition for /boot/efi

From then on, the installer should proceed automatically.


(Mvogel4949) #11

In the manual partitioning section, do I have the installer automatically create my mount points using LVM or choose them myself. If I choose automatically it gives me a /home partition that doesn’t seem right


#12

You need to create them yourself.


(Mvogel4949) #13

Ok. I created them along with the uefi, install is happening now… Thank you for your help


(Mvogel4949) #14

Thank You!!! I think it is set up correctly


(Mvogel4949) #15

[root@freepbx ~]# cat /proc/mdstat
Personalities : [raid1]
md125 : active raid1 sdb2[1] sda2[0]
5124032 blocks super 1.0 [2/2] [UU]
bitmap: 0/1 pages [0KB], 65536KB chunk

md126 : active raid1 sdb3[1] sda3[0]
457306112 blocks super 1.2 [2/2] [UU]
[==============>…] resync = 72.6% (332453632/457306112) finish=10.1min speed=205033K/sec
bitmap: 3/4 pages [12KB], 65536KB chunk

md127 : active raid1 sdb1[1] sda1[0]
5118976 blocks super 1.2 [2/2] [UU]
bitmap: 0/1 pages [0KB], 65536KB chunk

Looks like it is still syncing


#16

Glad you got it working. It might take some time to sync. You better leave it be until it finishes, so it can sync faster. Wait until the sync is finished to start using FreePBX, even though it is not required.

It seems you only have 3 RAID1 partitions. Have you created the swap partition? If you didn’t, then don’t worry. You can either create it afterwards or if your system has lots of RAM, probably you don’t need swap, but I might be wrong.


(Mvogel4949) #17

I thought I created it in the custom partition maker.


(system) closed #18

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.