Freepbx13/Asterisk13 I can not login to a queue as a dynamic agent

I have created a Queue “6000” with a dynamic ageht 201, I set restrict to dynamic agents as NO, when I dial 6000* I hear prompt to enter my agent number, i enter 201# and it just hangs up and I am not loged in ? If I change the queue settings to Static agent it works.

Connected to Asterisk 13.9.1 currently running on FPBX (pid = 2360)
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
– Executing [6000*@from-internal:1] Macro(“SIP/201-00000005”, “agent-add,6000,”) in new stack
– Executing [[email protected]:1] Wait(“SIP/201-00000005”, “1”) in new stack
– Executing [[email protected]:2] Set(“SIP/201-00000005”, “QUEUENO=6000”) in new stack
– Executing [[email protected]:3] Macro(“SIP/201-00000005”, “user-callerid,SKIPTTL”) in new stack
– Executing [[email protected]:1] Set(“SIP/201-00000005”, “TOUCH_MONITOR=1466606722.5”) in new stack
– Executing [[email protected]:2] Set(“SIP/201-00000005”, “AMPUSER=201”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/201-00000005”, “0?report”) in new stack
– Executing [[email protected]:4] ExecIf(“SIP/201-00000005”, “1?Set(REALCALLERIDNUM=201)”) in new stack
– Executing [[email protected]:5] Set(“SIP/201-00000005”, “AMPUSER=201”) in new stack
– Executing [[email protected]:6] GotoIf(“SIP/201-00000005”, “0?limit”) in new stack
– Executing [[email protected]:7] Set(“SIP/201-00000005”, “AMPUSERCIDNAME=Gary Clarke”) in new stack
– Executing [[email protected]:8] GotoIf(“SIP/201-00000005”, “0?report”) in new stack
– Executing [[email protected]:9] Set(“SIP/201-00000005”, “AMPUSERCID=201”) in new stack
– Executing [[email protected]:10] Set(“SIP/201-00000005”, “__DIAL_OPTIONS=Ttr”) in new stack
– Executing [[email protected]:11] Set(“SIP/201-00000005”, “CALLERID(all)=“Gary Clarke” <201>”) in new stack
– Executing [[email protected]:12] GotoIf(“SIP/201-00000005”, “0?limit”) in new stack
– Executing [[email protected]:13] ExecIf(“SIP/201-00000005”, “0?Set(GROUP(concurrency_limit)=201)”) in new stack
– Executing [[email protected]:14] ExecIf(“SIP/201-00000005”, “0?Set(CHANNEL(language)=)”) in new stack
– Executing [[email protected]:15] GotoIf(“SIP/201-00000005”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,29)
– Executing [[email protected]:29] Set(“SIP/201-00000005”, “CALLERID(number)=201”) in new stack
– Executing [[email protected]:30] Set(“SIP/201-00000005”, “CALLERID(name)=Gary Clarke”) in new stack
– Executing [[email protected]:31] Set(“SIP/201-00000005”, “CDR(cnum)=201”) in new stack
– Executing [[email protected]:32] Set(“SIP/201-00000005”, “CDR(cnam)=Gary Clarke”) in new stack
– Executing [[email protected]:33] Set(“SIP/201-00000005”, “CHANNEL(language)=en”) in new stack
– Executing [[email protected]:4] Read(“SIP/201-00000005”, “CALLBACKNUM,agent-login,”) in new stack
> 0x7f0d54018ba0 – Probation passed - setting RTP source address to 192.168.99.28:12030
– <SIP/201-00000005> Playing ‘agent-login.slin’ (language ‘en’)
[2016-06-22 10:45:24] ERROR[4157][C-00000006]: netsock2.c:305 ast_sockaddr_resolve: getaddrinfo(“FPBX”, “(null)”, …): Name or service not known
[2016-06-22 10:45:24] WARNING[4157][C-00000006]: acl.c:800 resolve_first: Unable to lookup ‘FPBX’
– User entered ‘201’
– Executing [[email protected]:5] GotoIf(“SIP/201-00000005”, “0?a5:a7”) in new stack
– Goto (macro-agent-add,s,9)
– Executing [[email protected]:9] GotoIf(“SIP/201-00000005”, “0?invalid”) in new stack
– Executing [[email protected]:10] GotoIf(“SIP/201-00000005”, “0?invalid”) in new stack
– Executing [[email protected]:11] GotoIf(“SIP/201-00000005”, “0?invalid”) in new stack
– Executing [[email protected]:12] ExecIf(“SIP/201-00000005”, “0?GotoIf(0?invalid)”) in new stack
– Executing [[email protected]:13] ExecIf(“SIP/201-00000005”, “0?Authenticate()”) in new stack
– Executing [[email protected]:14] Set(“SIP/201-00000005”, “STATE=INUSE”) in new stack
– Executing [[email protected]:15] Gosub(“SIP/201-00000005”, “app-queue-toggle,sstate,1()”) in new stack
[2016-06-22 10:45:28] ERROR[4157][C-00000006]: app_stack.c:594 gosub_exec: Attempt to reach a non-existent destination for Gosub: (Context:app-queue-toggle, Extension:sstate, Priority:1)
== Spawn extension (macro-agent-add, s, 15) exited non-zero on ‘SIP/201-00000005’ in macro ‘agent-add’
== Spawn extension (from-internal, 6000*, 1) exited non-zero on ‘SIP/201-00000005’
– Executing [[email protected]:1] Macro(“SIP/201-00000005”, “hangupcall”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/201-00000005”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,3)
– Executing [[email protected]:3] ExecIf(“SIP/201-00000005”, “0?Set(CDR(recordingfile)=)”) in new stack
– Executing [[email protected]:4] Hangup(“SIP/201-00000005”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 4) exited non-zero on ‘SIP/201-00000005’ in macro ‘hangupcall’
== Spawn extension (from-internal, h, 1) exited non-zero on 'SIP/201-00000005’
FPBX*CLI> exit

FPBX*CLI> queue show
default has 0 calls (max unlimited) in ‘ringall’ strategy (0s holdtime, 0s talktime), W:0, C:0, A:0, SL:0.0% within 0s
No Members
No Callers

6000 has 0 calls (max unlimited) in ‘rrmemory’ strategy (0s holdtime, 0s talktime), W:0, C:0, A:1, SL:0.0% within 60s
No Members
No Callers

PBX Firmware: 10.13.66-12
PBX Service Pack: 1.0.0.0

Gary.

That is not how you login to a queue. In feature code admin module you can see the feature code you use to login to a queue.

Try *45600 and check with the following command from asterisk cli if you have logged in.

queue show 600

Thanks, for the rely’s. It was staring me in the face, I tried *45 many time and did not work when I looked at feature codes again the blue enable button next to the feature was not ON, I can now log on and pause but I can not seem to get the *47 to work any thoughts.

Gary