Freepbx y firewall


(Argentina) #1

Buenos dias, tengo ya andando un freepbx sin problemas, el tema es que ahora tengo que abrirlo a internet para los que trabajan desde su casa, en principio funciona, el problema es que se reciben tantos ataques que empieza a funcionar muy mal, y tengo que desactivar el fail2ban para que funcione (que no es la idea)

El tema es el pbx está en 192.168.3.1 y router (fortinet) en 192.168.3.254

El tema es que fail2ban banea apenas la habilito la conexion la ip 192.168.3.254, ya que no “ve” realmente de donde viene el intento de conexion y al pasar esto bloquea a todos, porque obviamente las conexiones de afuera vienen del otro lado del router.

En fin, de que forma puedo solucionar esto??

Muchas gracias desde ya.


(Lorne Gaetz) #2

Config the router forwarding rules not to proxy the SIP traffic, have it pass through the source IP of the SIP packets.


(Argentina) #3

Correcto si le saco el nat al router fail2ban ya ve las ips correctamente. EL problema es que me quedo sin audio, llamando de cualquier linea exterior a un interno, tengo audio en el interno pero no del interno hacia afuera


(Argentina) #4

Amplio un poco mas, si pongo nat en el firewall, tengo llamadas externas sin problema.

Si saco el nat del firewall, la llamda en si llega, pero al atender solo hay audio en un sentido.


#5

Tenés que configurar correctamente los parámetros de red en SIP settings. Tanto la IP externa como la o las redes internas.


(Argentina) #6

Eso lo tengo ok, ip dinamica puesto el noip para que lo tome, y la red interna ok tambien, falta algun otro dato o configuracion?


#7

Le seteaste el parámetro NAT en yes a las extensiones que son remotas?


(Argentina) #8

desde donde veo eso?? Gracias!!


#9

Entrando a la definición de cada extensión,en la solapa advanced


(Argentina) #10

en la solapa advanced de las extensiones no aparece en ninguna parte NAT, solo lo encuentro en las opciones generales.


#11

Que versión de FreePBX estás usando? En la versión 14 o 15 el parámetro NAT especifico de la extensión está en la pestaña advanced de la extension


(Argentina) #12

Current PBX Version:

15.0.16.44

Current System Version:

12.7.6-1910-1.sng7


(Argentina) #13

Ahi estaba viendo que cuando la extension es legacy si tiene la opcion, pero todas las que tengo son sip normal, no se bien cual es la diferencia entre una y otra, ahora voy a probar con las legacy a ver si de esa manera tengo audio o no.


#14

Debería estar la opción de NAT ya sea chan_sip o pjsip


(Argentina) #15

Te juro que no está, no se si es xq tengo alguna otra cosa habilitada o deshabilitada que no aparece, En settings/advanced settings, hay una opcion que dice SIP nat, con las opciones yes, no, never y route, otra opción no encontré por el momento.


#16

Me parece que vos estás en la pestaña de SIP settings. Yo te decía que vayas a Applications->Extensions, entras a la extensión y dentro de la extensión vayas a su pestaña advanced.


(Argentina) #17

Si correcto en extensiones no está, lo otro que te decia es en las settings generales. En extensiones/avanzado no hay nada que haga mencion a nat (o aparece de otra forma?)


#18

Es muy raro

Fíjate acá para ver dónde tenés que buscar

https://wiki.freepbx.org/display/FPG/Extensions+Module


(Argentina) #19

bueno segun esto, en la solapa advanced tampoco figura la opcion de nat…

https://wiki.freepbx.org/display/FPG/Extensions+Module+-+PJSIP+Extension


#20

Ya no sé qué decirte, porque en mí FreePBX si aparece y es desde ahí donde se supone que se cambia la opción para cada extensión