FreePBX won't Install!

I have a laptop I decided to experiment on. It’s a HP 550 laptop with Intel Core Duo T5670 @1.8 Ghz which might be below of the recommended but I doubt it’s the issue here, 4gb of ram and 1TB HDD. When I plug in the usb drive with the FreePBX image on it it’ll start loading and right when it says the installation is about to start it just goes to a black screen and doesn’t continue. I tried hooking up the HDD on a different machine and finish the installation, but when I swapped the HDD it just won’t boot. I really don’t know what to do. I only plan to use the machine for one line see how it gonna work with a huawei modem to handle the calls and learn something about VoIP in the process, But I hit a wall. If anyone knows of a solution to this please help. I been messing with it for a week with no results and it’s just frustrating,

Do you have any other modern computer? You can install freePBX in Virtualbox on any operating system.
You just download the freePBX distro iso file and start a new virtualbox machine with this image (virtual DVD drive). Once installed, you remove the iso file.


EDIT: When you install an operating system onto a harddisk, you cannot connect the harddisk to a different computer and boot from it!!!

Often a video problem

I was desperately looking for solutions. I thought why not give it a try after all. As for running it on a virtual machine… I’m not sure cause if everything goes as it should I want to have it boot up and ready. While my primary computer is a laptop. And I don’t always keep it on. Is there any way around it? I believe the configuration is okay to at least install it.

Thought it might be a video problem. But it does boot the drive allows me to select what to install. And when it unpacks everything and says something like Installation is about to begin it’s just a blank screen. How do i solve this?

I use Intel NUCs with Linux Mint and always install freePBX as a Virtualbox VM. The advantage is that it’s agnostic of the hardware. So you can easily reinstall your freePBX server on new hardware. Just export and import the Virtualbox image :wink:

Open another virtual console (Ctrl Alt F1-4) and investigate

adding nomodeset solved the issue. everything worked smoothly after that. after days of frustrations :smiley: Thank you very much!

I have to install via console with the use of 0-modem-com1 to usb. No other connect is possible.
Handing over to VNC on the way lets the install stop at package 307 or 306
I use screen /dev/ttyUSB0 115200 8N1 command, read the image from usb2.0 and write to m2-sata-hdd.
Problem is that start window (choose install manually - automated - freepbx16asterisk18 - or whatever) is not really readable using this command. Therefore I have to guess, which line to choose.
Install time 4 to 6 hours. Is there a better command setting?

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.