Freepbx with WebRTC incoming calls answered but still ringing

Hello everyone!

I’ve been assigned a project for setting up freepbx to work with our WebRTC running with the JsSip client.

Everything seems to work fine when making outbound calls. The problem is when I’m calling the extension from an other phone. The WebRTC rings normally on the inbound call, but when answering the other end is still ringing, like there is no connection between the two ends. In my WebRTC I see the call as answered, but it is still ringing like it’s not answered.

What could it be? Please shed your lights, because I’m really stuck

Here are the asterisk logs:
asterisk log ->
Failed call log ->

Thank you

WebRTC is an api not an app, so you must have some sort of app running in your browser that is acting as a telephone extension, from your description. The jssip client is also another module it’s not a complete telephone extension app. So, is this app you are running in your browser that is actually doing the dialing and making the calls proprietary or open source? Can we get a copy of it? The first step in anyone helping would be to actually setup this app and test it on their setup.

Just out of curiosity have you seen this:

Lastly the symptoms you list seem consistent with the description of NAT issues, those issues are caused because while the control messages are passed the rtp ports are blocked. But if this is on a local lan there shouldn’t be blocking but possibly there’s an error in how the SIP communication is happening with WebRTC. I assume regular non-WebRTC extensions can call each other without a problem, correct? What about a WebRTC extension calling another WebRTC extension?

Hello and thanks for the answer. Yes the JSSIP is a JavaScript library we use with our softphone for our WebRTC.

Yes I’ve followed all the settings described there.

That’s right. Using zoiper softphone for example with a non-webrtc extension, works just fine.
It seems through the console that it takes a huge amount of time (about 40-60 seconds) to gather the ICE candidates. It seems like a local network problem. Tried the WebRTC from my home pc and it worked. So maybe a firewall or something else is creating a big delay in sellecting ICE candidates.
I have no clue what that might be

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.