FreePBX with VMware: missing packages kernel-devel and patch

Hi there
Has anyone gotten FreePBX to work as a virtual machine?
I’d like to run FreePBX as a virtual machine. I created a virtual machine (VM) using WMware Workstation 16 Player with SNG7-PBX-64bit-2104.iso (wwwDOTasteriskDOTorg/downloads/# - “Download Full ISO Now”). When I start the VM, I get the error message “You have specified that the package ‘kernel-devel’ should be installed. This package does not exist. Would you like to ignore this package and continue with installation?”.
The same error message appears with the package “patch”.
If I answer yes to both error messages, the new message appears “An unknown error has occured.”.
Thanks for any help.
Have a nice day.
Louis

Are you familiar with Virtualbox? Create a new machine in Virtualbox with the standard settings, Linux (other 64-bit). Add the freePBX-iso-file as an optical drive.
Boot the machine, install freePBX, reboot. If you see the install menu of the iso again, switch off the VM. Remove the optical drive connected to the iso. Start again. You are all set…pretty easy and stable. I just installed two current freePBX 16 distros.

Download from here

Thx for your Post.
I have now created a virtual machine with Virtual Box and the iso file from your link. After starting the VM, the installation runs through and after a final reboot, the selection of the different Asterisk versions appears. If I select a version and start it with Enter, the installation runs through again and after a final reboot the selection window appears again. So this is actually an endless loop. How do I break through them?

Read my first post again. :wink:
If the VM continues to start from the iso-file, shut the VM down (turn off), go to settings of your VM and remove iso-file (optical drive), then start your VM again.
Only do it, once you finished the installation.

Thank you again That was the solution. The secret is probably to take the iso file away from the system as bootable media. Anyway it works now.
Best regards
Louis

1 Like