Freepbx with fritzbox


(Greece) #1

Hello,
Recently i have setup a freepbx for my home with fritzbox 7590 registration works fine.
My only problem is on terminating a call.
If i terminate a call from a extension of freepbx the line is still open on fritzbox untill the other participant of the call terminates it.
Any ideas?
Thanks in advance.


(Andy) #2

Hello Mr. Hellrider,

I’m not quite sure, if FritzBox is a well known product outside Germany (where they are very popular in SoHo environments). So, if you are German, you would probably get more specific help by German VoIP forums, especially because I can’t imagine, your problem is related to FreePBX.

I am using FreePBX with FritzBox for nearly ten years now, and never had a problem like you do.

At least it would be nice to know, how you configured FreePBX to register with FritzBox. Sip or PJSIP? etc…


(Greece) #3

Hello,
I use fritzbox in Greece.
Maybe its my setup problem.
I have configure it as Sip.
Thanks.


(Greece) #4

Hello Starlifter,
I use fritzbox in Greece.
Maybe its my setup problem.
I have configure it as Sip.
Thanks.


(Andy) #5

How did you configure the trunk?


(Greece) #6

Hello,
My configuration of the trunk is:
In General tab:
Trunk Name Fritz
Hide Caller id No
Outbound Caller id My telephone Number
CID Allow any CID
Asterisk Trunk Dial System
Continue if busy No
Disable Trunk No
Monitor Trunk No
Dial Manipulation options i havent put anything
Sip Settings:
Outgoing:
Trunk Name Fritz
Peer details:
host=192.168.1.254
username=username of fritz extesion
secret=password of fritz extesion
type=peer
qualify=yes
dtmfmode=rfc2833
fromdomain=fritz.box
fromuser=username of fritz extesion
disallow=all
allow=alaw&ulaw&g726
insecure=port,invite
Incoming:
User Context 620(number of fritz extension)
User Details:
context=from-trunk
secret=password of fritz extesion
type=user
insecure=port,invite
fromdomain=fritz.box
disallow=all
allow=alaw&ulaw&g726
Register string username of fritz extesion:password of fritz extesion@ip of fritz
Thats all thanks


(David55) #7

I don’t know about Fritzbox, other than that it is also used in the UK, however, the above lines in your configuration mean that you are vulnerable to toll fraud, as all that is needed to make calls with the privileges of extension 620 are the fact that it is extension 620, and that can be found by brute force.


(Andy) #8

Hello!

General config seems ok.

Here is my PEER config:
username=620
type=peer
trustrpid=yes
sendrpid=yes
secret=***
qualifyfreq=600
qualify=yes
nat=no
insecure=very
host=fritz.box
fromuser=620
fromdomain=fritz.box
dtmfmode=rfc2833
context=from-trunk
canreinvite=no
authuser=620
allow=G722&alaw

USER config:
empty

Register string:
620:PASSWORD@fritz.box/620

To be honest, I don’t know why the things have to be configured that way - but for me it works without any problems. I’ve struggled with my FritzBox many years ago and found the above config somewhere on the internet.

EDIT: Just to make it clear: My config may be quite outdated! But it works and I dont’ want to change a runnig system

@david55
You might be right with that. But that would only be a problem, if the FreePBX System is exposed to the Internet. Typically, a FreePBX system behind a FritzBox isn’t reachable from the outside. The FritzBox is a “PBX” by itself and the only thing you do, is connecting an Asterisk system behind it.


(Greece) #9

Hello,
I have tested with your config and now it doesnt register at all.


(Andy) #10

Well, that’s not what we wanted…

Please show me screenshots of your trunk config.


(Greece) #11

Here it is:

![ip_2|690x388]


(Greece) #12


(Greece) #13


(Greece) #14


(Greece) #15


(Andy) #16

Ok, thank you! And that is now, what? Your working config, my not working suggestion, or a mixture of both?

If you want to try my config, then please empty the Incoming settings completely. No USER Context and no USER Details. The only thing filled out on that page has to be the register string.

Please also change the following entries on the Outgoing page:
insecure=invite (“very” is no longer supported…)

Just some questions or hints:

  • Your FritzBox and the FreePBX are in the same subnet?
  • Your FritzBox can be reached under fritz.box, or did you change the hostname?
  • 620 is your FritzBox extension name?
  • And just to be safe (sorry for that): you’ve entered your passwords correctly?

(Greece) #17

Hello,
I have completly put your config and still nothing

  1. Yes it is at the same subnet
  2. i didnt change host although i have put the ip in your config
    3)Yes password is right

(Andy) #18

That’s weird. As I said, I am using exactly this config without any changes for ten years now. With different FritzBoxes and different FreePBX Versions.

Maybe the FritzBox Firewall is blocking your registration attempts? Have you restarted the FritzBox yet?

Is your “username of fritz extension” different then 620 or, in general, the extension number? Newer FritzBoxes might have an extra username. My older system doesn’t have that, so username and extension number do match on my system.


(Greece) #19

I have fritz 7590 so the username is different from 620
I have tested also with my username and still nothing.
When i rolled back to my previous config register is fine


(Andy) #20

Sorry, if I couldn’t help you out. Unfortunately, your answers are not very precise. It isn’t clear what your exact config was. I don’t know why your system should behave differently than mine.

The one thing I would still try if I were you, is using your working config and just delete the “USER” entries on the Incoming tab.

Here is a website, I have found, which may help you further. It’s in German, but I think it should be possible to get the main points. Using Google translator might be an alternative.

You might want to try PJSIP instead of CHAN_SIP. So this would be worth a try: