FreePBX | Register | Issues | Wiki | Portal | Support

FreePBX with Digium SIP trunk no incoming calls but outbound work


(Viper53928) #1

We have FreePBX and a Digium SIP trunk that I setup using the following guide, but incoming calls are not coming in although outbound works fine. I called Digium support and they confirmed that our IP is not blocked from registering, so the issue appears to be related to the SIP registration. Can someone confirm if the information on that article needs to be updated or what the next steps are in troubleshooting should be? We also opened UDP 5060 and 10000-20000 and the issue still persisted.

https://support.digium.com/s/article/How-to-configure-a-Digium-SIP-Trunking-account-with-AsteriskNOW-and-FreePBX


#2

Using pjsip or chan_sip?
FreePBX version?
If on-site: Type of router/firewall? If in virtual machine, provide details.
If cloud: Who is provider?

Look at Reports -> Asterisk Info -> Registries. Does your trunk show as registered?

If not registered: check registry string (chan_sip). For pjsip, check that you have Registration Send and Authentication Outbound. If you still can’t register, post any messages in Asterisk log related to the registration failure.

If registered: Temporarily replace your Inbound Route(s) with a default route (any DID, any CID, destination is a known working extension) and see whether you can call in. If yes, post details about the Inbound Route(s) that aren’t working.

If registered but can’t receive calls with a default route: What, if anything, appears in Asterisk log on an attempted call? What, if anything, gets logged in your Digium account? What does caller hear? Does call show as connected on the calling phone?


(Dave Burgess) #3

The information you are looking for on this is in the /var/log/asterisk/full log file. If you followed the article correctly, you should be good to go.

From a “helpful mindset” position, incoming calls and outgoing calls are almost entirely unrelated. The fact that you can make outbound calls but not receive incoming calls are probably completely unrelated.


(Viper53928) #4

I accidentally forgot sip: at the beginning of the server_uri, so I am good to go now. The settings on that KB are still valid. Thanks for everyone’s feedback.