FreePBX VM's running under Hyper-V - Setting Change you need to make

Had a machine stop processing calls this morning - here is what I found:

Had some VM’s throwing TONS of these errors:

kernel: Clocksource tsc unstable (delta = 131717343 ns). Enable clocksource failover by adding clocksource_failover kernel parameter.

Come to find out it’s a bug (CentOS or Microsoft I don’t know…) that occurs when the VM is Live-Migrated - it actually hung a machine this morning which is why I found out about it - went and looked through all my running machines and it was occurring on 7 of them - the clock “De-Stabilizes” during the migration.

Simple solution - add this to /boot/grub/grub.conf and reboot when you can:


Put it at the end of the kernel line as an option and then reboot.

Here is the original article:

Also, if you update the kernel (yum) you need to re-apply this fix.

Ok - Scratch-Load Sangoma-7 is using grub2 - /boot/grub2/grub.cfg

I assume the change goes here:

BEGIN /etc/grub.d/10_linux

menuentry ‘Sangoma Linux (3.10.0-693.21.1.el7.x86_64) 7 (Core)’ --class sangoma --class gnu-linux --class gnu --class os --unrestricted $menuentry_id_option ‘gnulinux-3.10.0-693.11.1.el7.x86_64-advanced-d8867ba0-06e8-4c0c-8e81-3a0b81d48bb0’ {
set gfxpayload=keep
insmod gzio
insmod part_msdos
insmod ext2
set root=‘hd0,msdos1’
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos1 --hint-efi=hd0,msdos1 --hint-baremetal=ahci0,msdos1 --hint=‘hd0,msdos1’ e52e8132-3284-4c59-975f-4f4000bf4183
search --no-floppy --fs-uuid --set=root e52e8132-3284-4c59-975f-4f4000bf4183
linux16 /vmlinuz-3.10.0-693.21.1.el7.x86_64 root=/dev/mapper/SangomaVG-root ro crashkernel=auto biosdevname=0 net.ifnames=0 rhgb quiet LANG=en_US.UTF-8 clocksource_failover=acpi_pm
initrd16 /initramfs-3.10.0-693.21.1.el7.x86_64.img

1 Like

Actually, that change should most likely go into /etc/default/grub.

grub or grub2?

I’m just curious, are you using the FreePBX deployment? or building your environment from scratch?

GSnover, grub2

Please document this in a ticket so the devs can make whatever important updates they might want to.

dickson - Yes, FreePBX Distro.

cynjut - I don’t think they would be interested - they usually aren’t when it’s outside the scope of the actual distro. I am wondering if that setting would hurt as a default, but I guess if your machine didn’t support acpi_pm and that option was present if it would cause a problem? I don’t know.

I think LOTS of people are deploying FreePBX on Hyper-V which is why I posted it.

For what its worth, i just went through all our deployments on HyperV and i found one that is actually doing this right now. For what its worth, this one is an older PBIaf one, but exactly the same problem… I got a machine that I can at least do some triage on.

Yeah, I found 7 of my machines were doing it - Surprised the hell out of me - I looked at the machine that I first found it on this morning for hours scouring the logs - this was the ONLY thing being logged.

It’s a weird bug - I am guessing a Hyper-V bug but oh well.

Fills up /var/log/messages pretty fast too.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.