FreePBX using FreePBX-Distro-Net- & - the installation completed but boot hangs

Hi, I have tried for 3 days trying to install FreePBX using FreePBX-Distro-Net- & - the installation seems to be successful completed but unable to boot to FreePBX Main manu for setup… it hangs when boot to "welcome to CENTos rel. 5.5/setting clock (ok)/starting UDEV… it hangs on creating root device/mounting root filssystem…

Don’t know if that’s caused by any file crashed when downloading from your site or other PC (HP, with 2G Ram, 320G HD)problems? Please help and advise.

Appreciate all of your help.

To me that sounds like a hard drive issue. If Centos can not load after install. Have you tried it on different hardware?

Thanks Tony, you meant that change a Hard Drive or install on another PC may resolve the problem? The current Hard Drive is a 320 G seagate working HD with 4 partitions and was re-test with not error before installing the Distro. I wonder if there are some setup that we can try? the program was installed, load half way and hung right after displaying “starting UDEV”…Should I try to format the HD with NTFS or other file format first? THANKS

Hi Tony, per your suggestion, I got 3 NEW HD to try to install the Distro

so far have tried on 4th HD, installation completed but still boot half way and hung… showing:

setting up new root fs
no fslab.sys, mounting internal defaults
switching to new root and running init
unmounting old / dev
unmounting old /proc
unmounting old /sys
SELinux: disabled at runtime
type=1404 audit (1308857954.767:2)

then frozen


Iam not sure what is hanging it and there is no real logs to see since it wont boot. Have you tried a completely different machine?? Also how many drives are you installing on the machine when you do the install?

Thanks Tony for the quick reply -

yes, I have tried on another newer IBM PC P4 with 3G Ram.
I only use one new drive (connected to the one of the 4 sata banks, show as 6th Master HD at BIO setup screen) for this new installation. I disconnected the original HD on the PC (first Master HD) that was originally running xp before the installation. Any suggestions that may help to resolve this booting problem?

Many thanks to your kind help.

Can you just install plain Cent OS?

Hi Tony,

I tried to move the HD in the 3rd Master sata banks, currently, this is the only HD in this HP Pavillion a1610n with AMD Athlon 64x2 Dual Cord machine, but still had the similar booting half way issue. Display:

INIT: Version 2.86 booting
Welcome to CentOS release 5.5 (final)
press “I” to enter interactive start up (I did try press “I” but useless)
setting clock: (localtime) Thu Jun 23 21:13:04 EDT 2011 [ok]
starting udev: udevd-event[1250]: run-program: ‘/lib/udev/’ abnormal exit

I turn off the machine, and turn on many times again but got the similar above screen again but without the following:

udevd-event[1250]: run-program: ‘/lib/udev/’ abnormal exit

ANY other suggestions that I can tried please?


I just asked you to try to install just plain CentOS. This is a centOS issue and is pretty much unrelated to FreePBX.

Let us know if you can install just CentOS

Yes please download Centos5.5 and try installing it. What you are seeing is nothing to do with the Distro from what I can see since its not even booting.