FreePBX to Panasonic TDE Assistance

freepbx
siptrunk
Tags: #<Tag:0x00007f702c57e4c0> #<Tag:0x00007f702c57e308>

(Gordon Freeman) #1

I’ve been using information found from various form topics on this site to get a connection set up between a FreePBX installation and a Panasonic TDE200. I have it half-way there – I can dial the Panasonic’s extensions from FreePBX and the calls come through perfectly with full 2-way audio. However, I don’t even know where to start to make the opposite happen from the Panasonic.

Most of my configuration was gleaned from topic 48355 on this forum titled “Combining FreePBX with Panasonic KX-NCP500”

What I’ve done so far:

FreePBX

  1. Create a chan_sip trunk that references the Panasonic PBX
  2. Create an outbound route for the Panasonic PBX with the pattern 3XX – all the extensions on the panasonic are 301,302, etc
  3. Create an inbound route for the Panasonic PBX with a caller ID number of 3XX with the destination set to the FreePBX’s existing ring group that is confirmed to be functioning with a commercial SIP provider.

Panasonic

  1. In the Slot section (1.1), I added a V-SIPGW16 and configured it to use the FreePBX system as a SIP Trunk with Register Ability set to disable and the “User Part” settings in the Calling Party section set to PBX-CLIP
  2. In the CO Line settings, I set this connection’s Trunk Group Number to the same number that currently routes calls to and from other Panasonic PBX units that are connected with an IP-GW4 card.

Does anyone know what settings I could use to allow the Panasonic to dial out to the FreePBX? I’ve tried fiddling with the Dialing Plan (3.1.4), the Numbering Plan (2.6.1) , and the TIE Table settings (9.1) with no success.

Thank you!


(Ricardo) #2

What exactly make opposite from Panasonic (mainly basic setting Sip Provider, Account, and Registration Ability disable), because mainly outgoing calls not causing problem.
First of all Account should set User Name, Password Authentication Password (as Registration Ability set to disable it should set any number even it could be shortness).
First tip, if SIP configuration have been well done, you can check on Virtual V-SIPGW16 card port property (without change card to OUS state) and check the related port assigned to FreePBX settings on main tab “Connection” item is in service state “INS”.
If so, should check assigning V-SIPGW port trunk group which is mapping to a CO item, good practices and right way should separate into new trunk group from other PBXs.
It can check by accessing with Panasonic maintenance tool, item 10 CO & Incoming Call -> Sub-item 1 “CO Line Setting” and scroll down until identify Card type as “V- SIPGW16” and identified the configured port to link with FreePBX .
Last item at the right side it refer to trunk group it better to use a separated trunk in order keep separated dial rules with others gateways and stop causing confusion.
First item (left side) is the assigned line number to the port of the V-SIPGW16.
If have set a new group please check and enable onto test extension COS number (by default Parameters all trunk are enable).
If so and everything are alright on test extension you can dial * 37 and the line number assigned to V-SIPGW16 FreePBX port (*37 50 assuming 50 is the CO line assigned to V-SIPGW16 port), it will heard dial tone, therefore it can dial FreePBX extensions.
Instead of dial tone, (reorder tone it listen) it means to to;
Miss-configuration, restriction, fault, or disable.
It look hard but it works, only need have acknowledge about Panasonic system.


(Gordon Freeman) #3

We get a reorder tone when dialing *37, never have opportunity to input the CO Line (which is 60 in our case).


(Ricardo) #4

Have check COS setting of test extension as options "External Call Block" SIP channel group is not checked (noted this option if refers to different type of service "Day", "Night", etc.).

Could test extension dial to others PBX units?

PD: Could be possible to send Panasonic database by message?


(Ricardo) #5

Should assume problem does not refer to a lack of sip trunk activation licenses.
Preinstalled Activation Keys DSP16 ( activate 4 IP trunks H.323 or SIP) DSP64 ( activate 16 IP trunk h323 or SIP).
If default preinstalled Activation key are using for others trunks I.E H323 GW card, virtual port of SIPGW card it will be at failed state and couldn’t change to INS state.
You could check on Activation Key button on Slot configuration screen.


(Gordon Freeman) #6

There is a license and no other IP trunks are being used. I’m going to get back into this project today. I will post details soon.


(Kostas Mich) #7

I suggest you to use pjsip instead of SIP. I will post details soon.

Settings in Panasonic V-SIPGW
Main tab


Account tab

Register tab

Calling party

In menu 2-6-1 Other PBX add the FPBX numbering plan
In menu 9-1 also add your FPBX numbering plan and the trunk group that your PJSIP trunk belong

In FPBX



(Ricardo) #8

But if Panasonic extension CLIP ID is not set, it will send invite "From Header User Part = PBX-CLIP" as anonymous@anonymous

Panasonic with CLIP setting

ÄÄþÒINVITE sip:400@192.168.1.10 SIP/2.0

Via: SIP/2.0/UDP 192.168.1.1:5060;branch=z9hG4bK0000027b;rport

Max-Forwards: 70

To: sip:400@192.168.1.10

From: sip:101@192.168.1.10;tag=20806

Call-ID: 00006e18-df67c85e4ebc10009da70080f0300ba2@192.168.1.1

CSeq: 1 INVITE

Contact: sip:12@192.168.1.1:5060

Supported: timer,100rel

Session-Expires: 180

Allow: INVITE,ACK,CANCEL,BYE,PRACK,OPTIONS,REGISTER,INFO,NOTIFY,UPDATE

Content-Type: application/sdp

User-Agent: Panasonic-MPR07-V8.0101/VSIPGW-V2.3002

Content-Length: 236

Panasonic without CLIP setting

'"âð0#¢EÌ@ìDÀ¨eÀ¨

ÄÄ 8INVITE sip:400@192.168.1.10 SIP/2.0

Via: SIP/2.0/UDP 192.168.1.1:5060;branch=z9hG4bK00000f40;rport

Max-Forwards: 70

To: sip:400@192.168.1.10

From: sip:anonymous@anonymous.invalid;tag=10956

Call-ID: 000028a4-df67c85e6bdc10009da80080f0300ba2@192.168.1.1

CSeq: 1 INVITE

Contact: sip:12@192.168.1.1:5060

Supported: timer,100rel

Session-Expires: 180

Allow: INVITE,ACK,CANCEL,BYE,PRACK,OPTIONS,REGISTER,INFO,NOTIFY,UPDATE

Content-Type: application/sdp

User-Agent: Panasonic-MPR07-V8.0101/VSIPGW-V2.3002

Content-Length: 236


(Kostas Mich) #9

You can set CLIP-ID in menu 4-1-1, in tab ISDN CLIP and set Clip-ID the extension number and “CLIP on extension” as “Extension”.
But it works without CLIP also. The pictures that I posted earlier are from an interconnection that works 2 years now without any problems. I have made it with that way in about 10 customers.


(Ricardo) #10

But keep in mind you are allowing anonymous calls, which dangerous.
I have a case of TDE with split SIP ports connected to FreePBX and a VOIP Cloud with Register, and have receive strange calls with random numbers on “From Header User Part”.So what it mean Panasonic it listen and allow on SIP Register port configuration anonymous calls.


(Gordon Freeman) #11

I have gotten it working with some help from our Panasonic support person. His steps were very similar to those from tek640. However, I have 2 different trunks in FreePBX. For some reason, the new PJSIP trunk works for incoming calls from the Panasonic, but not for outgoing calls. The old SIP trunk still works for outbound calls. Any ideas?


(Ricardo) #12

“the new PJSIP trunk works for incoming calls from the Panasonic, but not for outgoing calls “ for PJSIP, panasonic PBX is listening SIP trunk access at port 35060.


(Gordon Freeman) #13

Ah, shoot. I made a typo, accidentally had 65060. Correcting that did the trick. Thanks everyone! Should I post some configs for future reference?


(Ricardo) #14

GREAT! CONGRATULATIONS!!! Up to you for sharing, as it seems each case were not concluded to one solution.

Good Luck.


(Gordon Freeman) #15

For anyone who may stumble on this later, here is what I ended up doing.

Phone System Interconnection Guide

Settings in Panasonic

1.1 Slot
Under the IPCMPR Virtual Slots, I added a V-SIPGW16 card to slot 3.
Under the V-SIPGW16 Port Settings
Main Tab: I set up Line 1 as a “Basic Channel” and set the IP to the address of the FreePBX server and Line 2 as "Additional channel for Slot3, Ch1
Account Tab: Set User Name and Authentication ID to the same value as the PJSIP username in FreePBX, similar with Authentication Password
Register Tab: Set “Register Ability” to Disable, leave the rest at defaults
Calling Party Tab: Set “User Part” to PBX-CLIP
Supplementary Service Tab: Set “CNIP (Receive)” to Yes and “Blind Transfer (REFER)” to Yes, leave the rest at defaults.
All other Tabs: Leave default settings

2.6.1 Number Plan > Main
Features Tab: Removed “Trunk Group Access” digits because they were “81” and this interfered with our extension numbering for the new phone system, this would be optional depending on the extensions
Other PBX Extension Tab: Added “8” to the first blank line to match the FreePBX’s 8XX numbering scheme

2.7.1 COS Settings
TRS Tab: Claimed a blank/unused COS line and named it “SIP Trunks” to use for other areas of the system

3.1.1 TRG Settings
Main Tab: Claimed a blank/unused Trunk Group for connecting the CO Line and named it “SIP Trunks”, then set its COS to the one used at 2.7.1

3.1.4 Dialing Plan
**Unsure if this is necessary, consider skipping this
Created a dialing plant table 2 and set it to 8XX, I believe it didn’t work

9.1 TIE Table
Claimed the first vacant line and set the “Leading Digits” to “8” to match the 8XX pattern of the FreePBX server, and set the Trunk Group to the one used at 3.1.1

10.1 CO Line Settings
Found the CO Line that corresponded to the Shelf/Slot/Port used in 1.1, set the CO Name to “SIP Connection” and set the “Trunk Group Number” to the one used at 3.1.1

Settings in FreePBX

Connectivity > Trunks > Add Trunk > Add SIP (chan_pjsip) Trunk
General Tab
Set name to something meaningful
Set maximum channels to 2 (or however many lines are set on the main tab of the Panasonic V-SIPGW16 settings)
pjsip Settings Tab
Username: Arbitrary, set to your choice, be sure it matches the setting of the account tab on the Panasonic
Secret: Arbitrary, set to your choice, be sure it matches the setting of the account tab on the Panasonic
Authentication: Outbound
Registration: None
Language Code: Default
SIP Server: IP address of the Panasonic system
SIP Server Port: 35060
Context: from-internal
Transport: 0.0.0.0-udp (this should be the default

Connectivity > Outbound Routes > Add Outbound Routes
Route Settings Tab
Route Name: Anything, make it meaningful
Trunk Sequence for Matched Routes: Set to the pjsip trunk created in the previous step
Leave other settings at default
Dial Patterns Tab
Set to a number then XX depending on the extensions used on the Panasonic. Our system uses extensions from 300 to 399 so mine was 3XX, but this is all relative to the target phone system

Click the red “Apply Config” button on the top left


(system) closed #16

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.