FreePBX to Amazon S3 Backup


First of all thankyou for making this feature available.

I’m trying to setup a daily backup to s3 though everytime I run it I get the following error log:

Saving Backup 2...done!
Intializing Backup 2
Backup Lock acquired!
Running pre-backup hooks...
Adding items...
Bulding manifest...
Creating backup...
Storing backup...
Whoops\Exception\ErrorException: S3::putBucket(*/*/*, public-read, ): [6] Couldn't resolve host ' in file /var/www/html/admin/modules/backup/ on line 222
Stack trace:
1. Whoops\Exception\ErrorException->() /var/www/html/admin/modules/backup/
2. Whoops\Run->handleError() :0
3. trigger_error() /var/www/html/admin/modules/backup/
4. S3->__triggerError() /var/www/html/admin/modules/backup/
5. S3->putBucket() /var/www/html/admin/modules/backup/
6. FreePBX\modules\Backup\Backup->store_backup() /var/www/html/admin/modules/backup/bin/backup.php:141

Any idea on where it is going wrong?
Do I need to enter anything more when pointing it to S3?

Thanks :smiley:

Backups to S3 are working for me, though I have to let FreePBX create the bucket for me, it fails if I attempt to use an existing S3 bucket. This part:

Couldn't resolve host 'topcashback-s3'

hints you may have a network issue, tho that is not a FQDN so I don’t know what’s going on. Double check your server config in Backup, make sure your modules are all up to date and if you can reliably reproduce this please file a bug at

Perfect thankyou very much

Letting FreePBX create its own bucket worked for me

Cross reference jira ticket:

100% fixed now, backup 13.0.10!

i can’t find this option in Web UI.
Is there any documentation on this as i would like to backup to Amazon S3 too.

@xrobau, i look high and low and i can’t find any menu on Servers. How did you enable this menu?

You need to actually be in the backup and restore module first. And in your OWN image you have it right there “Backup & Restore - Servers”

1 Like

thanks @tm1000 for pointing that out.