Freepbx Submit Extension Issue


(Canada) #1

My FreePBX box is 14.0.13.28. I have 500 extensions. Adding extensions was working perfectly, but today when I hit the 500th extension, a weird bug appeared. When I used to add an extension and hit submit, yes it would take a little while but no more than 30 seconds. Now that I’ve hit the 500th extension, when I hit submit, it just stays in a submission loop forever. Usually, it takes me back to the extensions list once the extension is added. I let it sit for 10 minutes, and it still stayed on submitting…(I usually use chrome)

As a test, I opened a different browser (Firefox), and the apply config button was there. So I applied the config and sure enough if I browse extensions, the new added extension is there, Yet from the browser I added it from (Chrome) it is still stuck in a submission loop never to go to the extensions page.

As another test, I submitted the extension from the gui from Firefox, SAME THING, the system sits in the submission loop…now if I open a browser I DID NOT submit the extention with, I can see the added extension, and I can apply the config from the browser I DID NOT add the extension from. This is so weird. Here are the things I’ve tried to solve the issue:

A. Cleared the cache in firefox and chome
B. Cleaed all data in firefox and chrome
C Applied updates to the FreePBX
D. Reboot FreePBX
E. Went to another computer and tried from Firefox and Chrome…same Issue.

None of the tried solutions solved the submission loop. All other options and the webpage/freepbx GUI load fast, but when I submit an extension I see this problem from any browser, and have to switch browsers to finish the extension add process…

Any Ideas?


(Canada) #2

It’s okay, I found the issue. It’s a memory paging issue. If you are viewing many extensions at once, add an extension, and then submit, one can reproduce this issue. However you view less extensions per page, and then add the extension, it will submit just fine, and view extensions. Weird, but at least I know now.


(Canada) #3

To Specifically solve the problem, I have to:

  1. Refresh the page specifically by going Application–>Extensions
  2. Make sure I am at the very TOP of the list (First set of extension) on the view extensions page
  3. Add the extension like I normally do and all is well.
    Maybe 4. (Sometimes deleting an extension, and then performing steps 1 to 3 seems to help too)

I can then add as many extensions as I want, and it is quite fast. I can then View and search any way I want to see them and all is well. It should be noted that if I perform the above steps before submitting a large set of records, that I cut my record submission time from 30 seconds a record to 3 seconds per record.

Hopefully, this helps others.


(Lorne Gaetz) #4

It’s not clear to me what the problem is. You’ve provided a list of steps to avoid the issue, can you provide a list of steps to reproduce?


(Canada) #5

I did right in my first post. Read the whole post please. The freeze on submit is the issue.


(Canada) #6

My solution has not fully solved the problem…has anyone else seen this issue?


(Canada) #7

Okay. An update, I was able to get all extensions in. Just a recap, as stated, once one is over 500 extensions, you may have to do the following, the behavior in my first post stands, and this is how I was able to work around it.

  1. Open a chrome incognito window.
  2. Created a macro to create an extension in FreePBX
  3. Once you hit submit, you will encounter the slow submit session behavior, however, I assure you as soon as you hit submit, your extension IS IN THE DATABASE, even though the session is stuck. Now just close this window, and repeat. Because you are using an incognito window the session freezing will not affect you and you can just move on to the next extension.

This bug does not affect the FreePBX GUI in any other way, you can view, delete, add etc on any page and all will be well. It just seems to be a bug with 500+ extensions, and the GUI. Thanks! :slight_smile:


(Dave Burgess) #8

Did you ever submit a bug report on this? While there are a few Sangoma guys that hang out here from time to time, if it isn’t in JIRA, it’s likely to not get any traction or fixed.


(system) closed #9

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.