FreePBX stops working at all in 1-2 weeks randomly

freepbx
Tags: #<Tag:0x00007fafc48b4ec8>

(Inga) #1

Ive got FreePBX 14 freely installed using ~20 VoIP-phones. It all works perfectly but in week or two (most of the times it’s a week) it stops working. No errors shown in GUI-web interface, the server keeps running, but phones do not work.
It all gets back to normal if I restore a Backup of a newly installed Distro (backed it as soon as it got installed and set up).
So, where do I dig, folks?

It also would help if you could tell me where to find much-much older versions of FreePBX, preferably ver. 2


#2

You need to take a look at the asterisk and Linux logs to see if you find something strange at the time that the system stops working.
Can you access the command line when this happens, or the server becomes completely unresponsive?


(Sshomi) #3

I am assuming you tried restarting asterisk and/or rebooting?

Are you recording calls and maybe running out of storage (df -h)? If you run out of storage it can cause the database to get corrupted and then asterisk may stop working.

Do you have enough memory and swap?


(Inga) #4

Yes the console and the whole system work fine, nothing unusual. I just thought may be it’s something common amongst ver.14-users… Ok I’ll try to look into it tomorrow, THANKS!


(Inga) #5

yep, tried that.
No I do not record calls and I surely did not run out of hard-memory, that I checked instantly.

Not sure bout these though. I’ll try to get back tomorrow with some more info, thank you


(Sshomi) #6

VoIP not working is almost all about Asterisk, not about any particular version of Fpbx GUI. Asterisk should just work always. Having it stop working after a week or two or a month or even a year would probably be unacceptable to most so no it most definitely is not common.


(Dave Burgess) #7

Local or remote?
Firewall configured for “that network” (wherever it is) correctly?


#8

What version of asterisk are you running? Is it by any chance one of the affected versions that present this exact behavior?


(Tom Ray) #9

This needs to be a little more descriptive. This is to vague to even consider what a possible problem is.

What else was done as a troubleshooting step to determine what the problem is? This step is rather extreme so it doesn’t really give us any indication of what is actually being fixed.

Honestly, no one can give you any real direction to go down. There is a complete lack of details on what they actual issues is. As I started previously “phones don’t work” is just to vague. There could be numerous reasons why this is happening. When things don’t work what is the actual status of things?

  1. Are the phones registered?
  2. Do they should a state of unavailable or unreachable?
  3. If they can’t accept inbound calls can they make outbound calls when this is happening?
  4. Do calls come in from the provider trunks?
  5. Is this PBX local to the phones or are there remote phones to the PBX?
  6. Is Asterisk actually still running when this happens? Just because the server keeps running doesn’t mean the services keep running.
  7. Do you even see attempts being made to the devices (for calls to them)?
  8. Do you even see attempts being made from the devices (register, invites, anything)?

Details are needed and required.

That is absolutely untrue.

This is also untrue as bugs in the GUI have caused configs and dialplan to be generated incorrectly and thus cause issues with functions such as calls. So yes, a particular version of a module in the GUI can break Asterisk.


(Inga) #10

Local, LAN. That’s interesting, coz now I remember I didn’t configure or even turn on the firewall FreePBX suggested


(Inga) #11

I can’t answer that for a few days, sorry sorry!


(Inga) #12

yeah I understand
I think I’ll do some tests and then get back here… Because I am running an old version right now (v. 2 or so - again, can’t give exact answer right now) because it works at least not-so-bad (but it also has problems, but that’s a whole another story). Thanks everyone I’ll be back


(system) closed #13

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.