FreePBX Statistics Bug

I’m not sure if this is a bug, but the FreePBX statistics is blank. I’m getting the following error on the CLI.

Loop Detected in Monitoring Script. Dying!

How can i fix this?

I’m on FreePBX version

After rebooting the system, The statistics remains blank.

Downgrade Firewall module to version.

1 Like

Thats the version i’m on.

Change log even mentions: Avoid potential infinite loop in monitoring daemon

Guessing it’s not actually fixed then.

Have the same issue with loop in

Same issue here.

Same issue on six of my servers.

Did anyone bother reporting this?

Looks like the issue report is here:

The update seems to have fixed the problem for me, but it’s only been running a few minutes.

Still having this issue on FreePBX / Asterisk 13.19.1.

Loop detected in monitoring script. Issue with Asterisk? Restarting!

Get the edge version of dashboard and this problem will be resolved.

Thanks @tm100–blazing fast response indeed!

Is there a simple series of steps to achieve what you suggest? I tried to execute a check for updated packages via the FPBX UI and it just stalls out. Perhaps this too will be rectified with a dashboard upgrade :slight_smile:

More details please.

Previously, when I went to Admin > Updates > Module Updates, selected Standard & Extended, and smashed the check online option, it would display the spinning wheel modal but never return results (had to F5). I just tried it again and it did go through.

As a point of qualification: this is installation is <48 hours old and it’s my first.

Question: Am I able to select and install the System Dashboard revision (01/27/19), and possibly System Firewall (09/11/18) without upgrading the remaining modules as well? I’ve not read fun things about upgrades.

In module admin you won’t be able to get the edge version, unless you enabled the edge repo in advanced settings.

I think you should do it from bash:

fwconsole ma upgrade dashboard --edge
fwconsole r

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.