FreePBX showing "Cannot Connect to Asterisk"


On my GUI, I’m getting a message in red saying “Cannot Connect to Asterisk”. I ran asterisk -r and connected successfully. I also ran fwconsole restart and got the messages,

Running FreePBX shutdown…

Running Asterisk pre from Core module
Stopping Call Transfer Monitoring Service
Core FastAGI Server is not running
Running Asterisk pre from Ucp module
UCP Node Server is not running
Shutting down Asterisk Gracefully. Will forcefully kill after 30 seconds.
Press C to Cancel
Press N to shut down NOW
[============================] < 1 sec
Running FreePBX startup…
Starting Asterisk…
[--------------->------------] 2 mins
In Start.class.php line 193:
Unable to connect to Asterisk. Did it start?

restart [-i|–immediate] [–] []…

It is likely asterisk is running as root. Asterisk should be started through fwconsole start. If it is run my systemd or manually then the permissions will be incorrect.


As I have mentioned, performing the command fwconsole restart just gives an error for Asterisk.

ps aux|grep asterisk

Is it already running though? Is something else setup to start it instead of FreePBX?

When I run this now after updating ubuntu I get this,

PHP Fatal error:  During inheritance of ArrayAccess: Uncaught ArgumentCountError: Too few arguments to function freepbx_error_handler(), 4 passed in /var/www/html/admin/libraries/Composer/vendor/filp/whoops/src/Whoops/Exception/FrameCollection.php on line 20 and exactly 5 expected in /var/www/html/admin/libraries/utility.functions.php:306
Stack trace:
#0 /var/www/html/admin/libraries/Composer/vendor/filp/whoops/src/Whoops/Exception/FrameCollection.php(20): freepbx_error_handler()
#1 /var/www/html/admin/libraries/Composer/vendor/composer/ClassLoader.php(444): include('...')
#2 /var/www/html/admin/libraries/Composer/vendor/composer/ClassLoader.php(322): Composer\Autoload\includeFile()
#3 [internal function]: Composer\Autoload\ClassLoader->loadClass()
#4 /var/www/html/admin/libraries/Composer/vendor/filp/whoops/src/Whoops/Run.php(117): class_exists()
#5 /var/www/html/admin/bootstrap.php(135): Whoops\Run->register()
#6 /etc/freepbx.conf(10): require_once('...')
#7 /var/lib/asterisk/bin/fwconsole(12): include_once('...')
#8 {main} in /var/www/html/admin/libraries/Composer/vendor/filp/whoops/src/Whoops/Exception/FrameCollection.php on line 20

I see this when either trying to run a command without root access or if the database is broken. One is obviously a much worse situation.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.