freePBX Remote phone or Remote SIP app Help

configuration
Tags: #<Tag:0x00007f7027bc5158>

(Defcomllc) #1

FreePBX 15.0.16.75 full updated

I am having trouble finding a way to get remote phones or softphones/SIP apps on mobile devices or desk phones connected to my freePBX remotely. Hoping someone is doing this and can advise what I need to configure to get it through.

Some background. I have freePBX setup with static IP, I forward port 5060 and 10000-20000 in my Gateway/Router to freePBX internal static LAN IP. The problem is the freePBX firewall 100%. If I use a VPN on my android phone when on 4G cell service, Bria or Groundwire SIP phone app registers and I can send and receive calls. Works great. I did need to add my VPN IP range to the firewall trusted zone to make that work.

The problem is, for situations where the VPN cannot be used, I am unable to get Bria to register and connect to freePBX whenn freePBX firewall is enabled. freePBX firewall is 100% blocking this and I am pretty sure its because of the unknown IP address of my cell phone/4G data connection. Same goes if someone is working from home and using their softphone app on their cell connected to their house wifi…that home DynamicIP is not trusted in freePBX firewall. If I disable Firewall (which we dont want to do) but for testing purposes, Bria connects from my android phone on 4G data no problem. Moment I turn firewall back on, no go. I tried using a DDNS that resolves to my IP address, and add my static WAN IP to trusted zone in firewall but that also doesnt work.

Any suggestions? What am I missing here? Gotta be a way to get desk phones and softphones connecting to freePBX remotely with everyone working remotely now with everything going on in the world…

Any help would be greatly appreciated


(Lorne Gaetz) #2

The feature you’re looking for is the ‘Responsive’ firewall option:
https://wiki.freepbx.org/display/FPG/Responsive+Firewall

setup video: Open Source Pro Tips #2 - Firewall Basics


(Defcomllc) #3

Thank you for the quick reply. I do have responsive firewall enabled, but I see these additional items not enabled. Are you saying just turn on SIP Protocol option and that will fix my issue??

Imgur


(Defcomllc) #4

Didnt see the second link to video you provided. Ill watch that now.


(Defcomllc) #5

Thank you for the link. The video answered my question. I did have responsive firewall enabled and couldnt figure out why it wasnt working… I had to enable SIP within Responsive Firewall. Thanks again


(system) closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.