FreePBX Recording Can Still Hear even if the call was transferred

Hi Guys,

Anyone here experience this issue:

Inbound call goes to Queue and answered by 1001 extension and customer would like to transfer the call to 1002. After the call when they review the call recording and it just 1 recording, on that recording 1001 can still hear the recording between the customer and 1002 extension.

1001 should not hear the recording between customer and 1002 since it was transferred.

Any advise?

Thank you,

Any updates on this please?

@FreePBX moderator what are you thoughts on this. Thank you.

What are your recoding rules? Do you record on the trunk, inbound route, queue, extension?

Tried the following
Extension settings - Recording option, set to YES
Inbound Route - Disabled

Even local to local calls then transferred to local experience the same thing.

What if you set the queue to record but not the extensions?

@comtech We need to keep enabled the recordings on extension settings, set to YES, for inbound and outbound calls that directly made or goes to the extension.

Even if your suggestion will work, it is still an issue on extension to extension doing call transfer.

Customer Incoming Call >> Received by 1001 >> Transferred to 1002 (Sales)

On the example there should be 2 recording file.
Customer to 1001 - 1st recording
Customer to 1002 - 2nd recording

But when you review the call the recording, its just a 1 recording file for the whole conversation.

Can you replicate also from your end?

I am not sure what you are doing is unexpected then. You would need to confirm with Sangoma. If you think it is a bug, you can submit a bug report. System Dashboard - Sangoma Issue Tracker (

That will give you a definitive answer from Sangoma.

There is a small service that is part of the core module called core-calltransfer-monitor that tracks transfers and maintains the recording.

I don’t see a way to disable this functionality, but you could try manually stopping the service and see whether that does what you want:

fwconsole pm2 --stop core-calltransfer-monitor

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.