FreePBX Phones not registering after outage


(United States) #1

Our FreePBX went down today when our UPS failed. Upon replacing the UPS and getting it back online none of our phones are registering. We have Yealink phones and they all have valid IP’s on the same VLAN as the PBX and we can access them through their web interfaces fine. We are also able to access the FreePBX web interface and able to ping the phones from within asterisk, but the phones all fail to register. I have tried re-provisioning and rebooting the phones. Have also tried pushing the templates back out.


#2

Does anything appear in the Asterisk log when the phones attempt to register? If so, the entries should show what’s wrong (pjsip vs. chan_sip), incorrect password, etc.

If not, do registration attempts appear with sngrep or tcpdump? If so, that’s a FreePBX firewall or fail2ban issue.

If not, does the phone’s web interface show configuration for the correct server IP and port? If not, you have a provisioning issue.

If yes, does the server have the correct IP address and is it listening on the correct port?

If so, you have a LAN issue.


(United States) #3

We got the phones to register. Turned out a bunch of modules weren’t loading and had to manually started. We’re now able to call internally extension to extension but no outbound calls work coming or going.


(United States) #4

Found that our DAHDI Config is missing. We should be showing FXO Ports 1,2,3,4 but instead it appears blank like the card maybe isn’t recognized.