Freepbx outbound call not working via Mitel 3300


(Adam) #1

Hi

I am having an issue making an outbound call from freepbx v14 connected via a trunk to a Mitel 3300 that has the SIP provider terminated to it. This is from the UK

I can make inbound calls fine but outbound is failing. I believe it is down to my dial pattern but have tried a few combinations and made no difference. From what I have read 0044+0. should work as a catch all.

My trunk works and I have an outbound route setup connected to that trunk.

In my dial plan just now I have

0044+0.

I have tried

0XXXXXXXXXX

Any ideas where I am going wrong any help much appreciated.

Regards

Adam


#2

If the Mitel will accept a number in the same format you dial it, e.g. 07702212345, then try for your Outbound Route dial pattern:
prepend: (leave blank)
prefix: (leave blank)
match pattern: 0Z.
callerID: (leave blank)

If the Mitel requires e.g. 00447702212345, then try:
prepend: 0044
prefix: 0
match pattern: Z.
callerID: (leave blank)

These both assume that the Dialed Number Manipulation Rules for the trunk are empty.

If you still have trouble, post a new log. Please don’t post images of log files. Copy the log data into a text editor and redact it as desired. Then paste the result at pastebin.freepbx.org and post the link here. If the log for the call is short (fewer than 50 lines), just paste the redacted log into your post.

On incoming calls, what format is used for the caller ID? For the dialed number? On a ‘sane’ system, it would be logical for the numbers on outbound calls to use the same format.


(Adam) #3

Thanks for coming back to me Stewart1.

I used

Outbound Route dial pattern:
prepend: (leave blank)
prefix: (leave blank)
match pattern: 0Z.
callerID: (leave blank)

There is only outbound dial prefix on the Trunk as you need a 9 to dial out from the Mitel.

I set the settings as above and got the following

https://pastebin.freepbx.org/view/fd30d80b

Inbound call format is 07702123456

Regards

Adam


#4

If the mitel needs a 9 to dial, you need to prepend the 9 to the outbound call. You can do that with the outbound route prepend field.


(Adam) #5

I prepend the 9 to the outbound call as advised but still get the same issue. Here is my debug

Regards

Adam


(Lorne Gaetz) #6
[2019-12-02 13:25:03] VERBOSE[57321][C-00000000] app_dial.c: Called PJSIP/907702201813@mitelpjsip
[2019-12-02 13:25:28] VERBOSE[57321][C-00000000] app_macro.c: Spawn extension (macro-dialout-trunk, s, 33) exited non-zero on 'PJSIP/3001-00000000' in macro 'dialout-trunk'

Call is attempted, nothing is coming back from the other end. Looks to be a signalling issue or you can investigate logs at the other end.


(Adam) #7

Thanks. I will get in touch with the Mitel provider


(system) closed #8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.