Freepbx on google compute engine

Hello is anyone running FreePBX on google compute engine? I’ve configured everything successfully, but can’t get outgoing calls to stream voice (no sound on the outbound calls), I can receive the voice into the google server though.

I personally haven’t tried a GCE instance because they haven’t quite figured out the import of a vmdk yet, but I digress. Typically audio issues are firewall/NAT related. I assume you figure you have all the outbound firewall rules on your GCE correct to allow RTP traffic?

were you able to figure this out? I have the same problem…

fresh install on Google Compute

I switched to digital ocean, that helped :slight_smile:

Alright, it’s much easier than I originally made it. You can import directly from VirtualBox (or your live PBX I would guess) into Google Compute Engine using the import tool available in the Google Compute console. Much easier than I made it. Just use this tool and you can import an existing VM into Google Compute Engine. Super easy to do.

_I was finally able to get the official distro up and running in Google Compute Engine. There’s no simple, direct process, but it’s doable. It requires using VirtualBox and Amazon Web Services as Google has some interesting requirements for uploading images to them directly. _

Here are the steps that I took:

_1) Install the distro in VirtualBox on your local machine. I downloaded the ISO and used it as a Live Disc for the install. I used VHD as the file format for the disk. You’ll want to keep the disk size under 100GB because that’s the largest size allowed with the import tool in Google used in a couple steps. I went through the initial steps so I could set a default root password and user for the GUI. After it’s setup, power off the virtualbox machine. _

2) Upload the VHD file to Amazon S3. I used a location that’s publicly accessible, but I’m not sure that’s required.

3) Import the VHD to EC2 using the EC2 import tool. I wasn’t using the AWS CLI in Windows, but the command should be similar in other OSes. The command I used looked like this:
aws ec2 import-image --description “FreePBX” --disk-container "{ “Description”:“FreePBXImage”, “UserBucket”:{ “S3Bucket”:“BUCKETNAME”, “S3Key”:“public/FreePBX.vhd” } }"
Note that you’ll want to use your bucket name and the appropriate VHD file name. My file was uploaded to a folder in my bucket named public, as I set the permissions for the folder to be publicly accessible. Credit to this author for outlining the steps I used:

_4) Launch the instance in AWS using whatever size EC2 you prefer. You’re not going leave this running very long, so feel free to use some decent specs. _

5) Import the EC2 instance into Google Conpute Engine using their free import tool powered by CloudEndure. After setting up the CloudEnsure account you’ll need to SSH into the EC2 instance to run a couple commands. They provide good instructions on their website once your account is setup. Here is Google’s documentation on it:

_The whole process takes quite a few hours, but most of that time is just waiting for uploads and imports to complete. After the import is done you’ll have your FreePBX distro running in Google Compute Engine. I like to take a snapshot of my VMs before I start messing with settings because mistakes happen. _

For security purposes I changed my SSH settings to only allow SSH using key authentication, no password logins allowed. Gotta keep the hackers away!

I can share more if anyone is interested as I’ve been wanting to get this done for over a year and I was very happy to find the import tool. I was even happier to find out that it’s free (for now).

I have unsuccessfully attempted several times to upload my live FPBX into GCP. After running the commands in the tutorial I get the following errors:
Could not find platform independent libraries
Could not find platform dependent libraries <exec_prefix>
Consider setting $PYTHONHOME to [:<exec_prefix>]
ImportError: No module named site

Did you (or anyone else) run into this?

I know you’ll need to install an app on the Live FreePBX machine. I’m wondering if that app didn’t install correctly before you started the process?

download iso,then into vmdk ,then gce ,then nat .ok

I’ve had no issues with GCP using this script:


Thanks for the insight. I’m attempting the same import into GCP. The request for generation of a JSON private key returns an error “The Google Cloud Platform credentials you provided are either invalid or have insufficient permissions”.

Might you have any suggestions for how to proceed?