FreePBX on AWS packet retransmission error

Hello everyone !

First thanks in advance to everybody that will help me :slight_smile:

A bit of context is needed first :smiley:

I am a young IT enthousiast interrested in learning basic VOIP and i tried deploying FreePBX 15 on a debian 10 VM on my computer folowing the tutorial found on osslabs (cannot send the link as i am a new user)

And IT WORKED LIKE A CHARM !
I swaped the bind port of chansip and PJsip (5060 - 5160), and created 2 chansip extensions (1000 & 2000)
I used 2 sip clients to connect to them and it worked, i could call between the 2 without a problem etc… !

So now that i know it works, i created an EC2 machine in AWS with the debian 10 image, and did the same install setup on it.$
I linked my sip clients to the newly created 1000 and 2000 extensions in the AWS EC2 machine and well, it connected !

I am now trying to call between the 2 extensions and the call is going trough !
But after 5-6 seconds of the call, it hangs up…
And i cannot hear myself trough the call :confused:

After looking at the Asterix log file i can see this error:

1805 [2021-07-24 14:31:14] WARNING[1481] chan_sip.c: Retransmission timeout reached on transmission 2b0c3accabbf41ffa70f7d4afaa828ba for seqno 18561 (Critical Response) – See wiki".“asterisk”."org/wiki/display/AST/SIP+Retransmissions

1806 Packet timed out after 6400ms with no response

1807 [2021-07-24 14:31:14] WARNING[1481] chan_sip.c: Hanging up call 2b0c3accabbf41ffa70f7d4afaa828ba - no reply to our critical packet (see wiki".“asterisk”."org/wiki/display/AST/SIP+Retransmissions).

And after looking at the link provided, it tells me that it is a firewall or nat error, but my AWS security group is configured so all the trafic comming in and going out of my machine is allowed.

And i am a bit concerned as why this don’t work ?

So if one of you guys have had the same issue or can give me a hint or else on how to soluce the problem, it would be absolutly delightful !

Thank you all and have a great day !

In Asterisk SIP Settings, confirm that External Address and Local Networks are correctly set. If you change these, you must restart Asterisk.
If you still have trouble:

At the Asterisk command prompt, type
sip set debug on
You should see
SIP Debugging Enabled
Then make a test call. Paste the Asterisk log for the call (which will include the SIP trace) at pastebin.freepbx.org and post the link here.

If you are too new to post links, just post the last eight hex characters of the link URL.

The Asterisk log is at /var/log/asterisk/full , or can be viewed in the GUI at Reports -> Asterisk Logfiles.

Hello Stewart1 :smiley:

Thanks for your reply !

After going to Setting -> Asterisk sip settings, i figured out that the server autodeteccted the external Elastic IP that AWS provided me, but the internal IP was not set !
And as AWS use NAT by default (i diden’t knew that before searching), i had to put my internal network in CIDR form and VOILA !

I can now call between extensions, IVR etc… !

Thanks for your help !

I wish you a wonderful day !

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.