FreePBX not responding to incoming requests on 1443

configuration
freepbx
Tags: #<Tag:0x00007fafbe097020> #<Tag:0x00007fafbe096e18>

#1

I am using tcpdump to confirm that, I am seeing traffic hit port 1443 on external firewall and on FreePBX so port forwarding is working. I don’t see any return packets coming from PBX thou.

I can use https://USERID:PASSWORD@pbx.domain.com:1443/sangoma/0/fw500.rom locally and get the download prompt. Using this URL externally times out. Again, I see the request into PBX, but no reply.

FreePBX 15.0.16.42 (distro)

any ideas?
thanks


(Lorne Gaetz) #2

Is the pbx firewall configured to allow the source IP?


#3

No, I thought the responsive firewall handled that for me? 1443 and 1194 are port forwarded to PBX and is open to internet.

The night before the phone was working but had one way audio and the VPN connected automatically without issues, so I took another location, the phone had one way again, using tcpdump I could see return packets were going to home IP still. I assume this was programmed into phone still, so I factory restarted and phone would no get a reply back from FreePBX anymore.

I brought the Sangoma phone home again and plugged in and I see server replying! however it isn’t registering or using VPN like it did yesterday.
Update 20 mins later. I factory reset and now freepbx isn’t replying to phone. Acts like fail2ban is blocking responses but I don’t have anything blacklisted in intrusion detection

Thanks for the help.


#4

in the responsive firewall I enabled https on internet and it started working.