FreePBX not Requesting Login


I have 2 Asterisk servers in different cities. Recently, I’ve noticed when opening FreePBX on one of them, that it isn’t asking for login details. I recently changed the password for wwwadmin & maint on both servers. One server pops up asking for the username/password, but the other just goes straight into FreePBX. I’ve tried changing the password again using passwd-amp, and passwd-master, but it doesn’t seem to re-enable the password on FreePBX.

It’s not a cached password issue on IE or Firefox, as I’ve used different machines, and changed the password, and it still goes stright into FreePBX.

Where would the setting to request a password be in the config files? I couldn’t see any files in /etc/httpd/conf, /etc/httpd/conf.d or /etc/pbx that say anything about requiring a password, or there being a restricted area!

Any help, or suggestions would be most appreciated!



Check /etc/amportal.conf and /etc/asterisk/manager.conf for the admin password. Also if you are using passwd-master then it sounds like you are using PiaF.

That’s an apache verification routine and is set up in the

/etc/httpd/conf/httpd.conf file

If you scan through the file you’ll find a bunch of entries kind of like this:

#Password protect /var/www/html/admin <Directory /var/www/html/admin/> AuthType Basic AuthName "Secure " AuthUserFile /usr/local/apache/passwd/wwwpasswd Require user administrator director </Directory>

These are the directives that set up directory security in apache.

I’m no expert in this, but you can google “apache security” and figure something out.

I had a reverse problem several weeks ago where apache was asking for a password when it shouldn’t.


Thanks for the reply.

I believe the system is ConcordIAX, however it was installed by someone else, and I’ve since been asked to manage it.

I’ve checked those 2 files, amportal.conf has
AMPMGRPASS=B12e4327ec672 (Not the password I set for wwwadmin)

And manager.conf has the following:
secret = B12e4327ec672 (The same password as above)

So there are passwords in those 2 files, although not the ones I set, and it’s not requesting login details when opening http://pbx-ip/admin

I opened /etc/httpd/conf/httpd.conf but couldn’t find any reference to “/var/www/html/admin” or “AuthType”. I also opened httpd.conf on the PBX that does request login details, and couldn’t find those details either.


They my be in “Include files”

If you’ll scan through those files and look for “include”, there will be a reference to a file. Check to see if that code is an any of those files.



Thanks for the reply again.

I found some entries similar to the above in /etc/pbx/httpdconf/pbx.conf

When I compared it to the working PBX’s pbx.conf, the section for /var/www/html/admin was missing, so I’ve copied that section into it, and restarted amportal. However, it still doesn’t request login details!


Try restarting httpd
(service httpd restart)



Yep, that worked! Asks for the logon details now!

Thanks for your help!



Have a good weekend and may the Easter Bunny lay lots of chocolate eggs around you!!