FreePBX not recording supervised transfer

Greetings all. This might be a misconfig on my end, if it is please point it out.

I have 3 extensions set to record (via force option on the extensions) inbound internal and inbound external calls. The idea is to capture customer conversations but they transfer calls around (hence the internal recording). Call flow is inbound call -> ring group -> someone answers and then transfers to the right person.

They complain they never see the customer recording. What it appears is going on is that they are doing a supervised transfer to the final destination of the call telling them what’s up before the call gets transferred. I have recordings from the initial call and the supervised part of the transfer. But when they call is sent to the final destination there is no recording.


Official Distro
FreePBX v13
Asterisk v13

Make sure your “internal” calls are getting recorded as well as the “external” calls.

I understand that the call is between a local extension and an external caller, but the logic for the automatic recording may not recognize the transfer as an external call.

If that fixes (and even if it doesn’t) you might want to submit a ticket for that.

I mocked this up on my dev system and it’s the same thing. Just to be clear here it is splayed out.

External caller --> answered by x500 --> transfer to 501 --> transfers again to attach call to 501
| | |
Recorded Recorded Does not create record

When you say ticket, you mean a support ticket or a bug submission?


Yup. They’re the same thing.

You talking about paid support?

Nah - this should be a normal issues ticket. It seems like a bug.

Can you give a brotha a link? I am not 100% sure where that might be.

Thank you kind sir.

1 Like

FREEPBX-13830 has been created.

Just as some added info. I did try setting all call types to force and yes with no effect. I even tried to use on demand recording once the call has been fully transferred and still no go. However a blind transfer seems to be fine.

How are you initiating the attended transfer? Are you using a phone button or the Asterisk feature code? If you haven’t tried the Asterisk feature code (*2 by default), does it make a difference?

Phone button in real life scenario as well as my tests. I will give that a shot right this second.

Stupid question what’s the process to doing it that way? I cannot seem to make it work properly nor can I find any documentation on completing an attended transfer via feature code.

While on a live call enter *2 (or whatever the feature code is set to), you will hear the recording “transfer”, you enter the destination extension and wait (or enter # to terminate the wait) and proceed from there.

Sorry it was the last part of the transfer I was missing on that. I have to hit *2 again to complete the transfer. So it ended up being *2 - ext - *2

But when doing that it appears to work. Not only does it record but it seems to snag the attended transfer portion and the actual conversation (post final transfer) all in one recording. So what does this mean? Softkeys on the phones are not utilizing the proper codes? This has been tested on Cisco SPA and Sangoma phones with the same result.

This has always been a limitation. Asterisk looses the channel variable on the attended transfer when doing SIP transfer which is how every phone has to do a transfer.

So essentially the feature code is the only way to do it?

Ya based on last time.we tried to save this. Maybe things in asterisk 13 have improved but 2 years ago with Asterisk 11 it was not working.

This is on Asterisk 13 so I assume it is still an issue. Thanks much for the info.