Freepbx not recognizing A101 E1 card after power disrruption

We have a Sangoma Freepbx appliance (FPBX60) with a Sangoma A101 E1 card running Freepbx 16 that has been working fine for months. Today there was a power outage and after it was restored now Asterisk/Freepbx cannot use the card.

Card is seen by the wanrouter utility:

wanrouter hwprobe


Wanpipe Hardware Probe Info
1 . AFT-A101-SH : SLOT=4 : BUS=8 : IRQ=17 : CPU=A : PORT=1 : HWEC=0 : V=40

Sangoma Card Count: A101-2=1

#lspci
08:04.0 Network controller: Sangoma Technologies Corp. A200/Remora FXO/FXS Analog AFT card

dahdi_hardware

pci:0000:08:04.0 wanpipe- 1923:0040 Sangoma Technologies Corp. A200/Remora FXO/FXS Analog AFT card

But Freepbx just lists it as:
Sangoma Technologies - undefined [ undefined]

And it will not let me edit the card from Dahdi Config. If I run the setup-sangoma script it detects the card and I can configure but the card is still not seen by dahdi or freepbx.

dahdi_cfg -v

DAHDI Tools Version - 2.11.1

DAHDI Version: 2.11.1
Echo Canceller(s):
Configuration

SPAN 1: CAS/HDB3 Build-out: 0 db (CSU)/0-133 feet (DSX-1)
30 channels to configure.
DAHDI_SPANCONFIG failed on span 1: No such device or address (6)

system.conf has the proper parameters which had worked before. There is a wanpipe1.conf with the correct info.

dahdi_scan (no output)

Maybe the card got damaged by the power outage? I really do not know since I can somewhat detect it with some of the wanrouter scripts. Any recommendations on how to fix the problem? Any other debugging I can do to determine if the card is damaged? Thanks