FreePBX new install, no audio in or out, IVR audio works

Asterisk (Ver. 10.12.0)

Ports forwarded:
4569 UDP
5060-5082 UDP
10001:11001 UDP

faxdetect=yes
vmexten=*97
context=from-sip-external
callerid=Unknown
notifyringing=yes
notifyhold=yes
tos_sip=cs3
tos_audio=ef
tos_video=af41
alwaysauthreject=yes
useragent=FPBX-2.10.1(10.12.0)
disallow=all
allow=ulaw
callevents=no
bindport=5060
jbenable=no
defaultexpiry=120
maxexpiry=3600
minexpiry=60
allowguest=yes
srvlookup=no
registerattempts=0
registertimeout=20
notifyhold=yes
rtptimeout=30
g726nonstandard=no
t38pt_udptl=no
videosupport=no
maxcallbitrate=384
canreinvite=no
rtpholdtimeout=300
rtpkeepalive=0
checkmwi=10
notifyringing=yes
nat=yes
externip=external IP
localnet=192.168.1.0/255.255.255.0

When I run an RTP debug, I don’t see any RTP traffic.

Did you adjust etc/asterisk/rtp.conf to match the lowered number of rtp ports?

I did. Here is what is in my /etc/asterisk/rtp.conf file
rtpstart=10001
rtpend=11001

My SIP provider is phonepower aka voip.com

I cleansed the external to address to x.x.x.x
I noticed a few things when I look at this that may need to be adjusted.
RTP keep alive
External address appends with :0
One DTMF is set to rfc8233 but I switched to InBand - I must have missed one

This is a sip show settings
Global Settings:

UDP Bindaddress: 0.0.0.0:5060
TCP SIP Bindaddress: Disabled
TLS SIP Bindaddress: Disabled
Videosupport: No
Textsupport: No
Ignore SDP sess. ver.: No
AutoCreate Peer: No
Match Auth Username: No
Allow unknown access: Yes
Allow subscriptions: Yes
Allow overlap dialing: Yes
Allow promisc. redir: No
Enable call counters: No
SIP domain support: No
Realm. auth: No
Our auth realm asterisk
Use domains as realms: No
Call to non-local dom.: Yes
URI user is phone no: No
Always auth rejects: Yes
Direct RTP setup: No
User Agent: FPBX-2.10.1(10.12.0)
SDP Session Name: Asterisk PBX 10.12.0
SDP Owner Name: root
Reg. context: (not set)
Regexten on Qualify: No
Trust RPID: No
Send RPID: No
Legacy userfield parse: No
Caller ID: Unknown
From: Domain:
Record SIP history: Off
Call Events: Off
Auth. Failure Events: Off
T.38 support: No
T.38 EC mode: Unknown
T.38 MaxDtgrm: -1
SIP realtime: Disabled
Qualify Freq : 60000 ms
Q.850 Reason header: No
Store SIP_CAUSE: No

Network QoS Settings:

IP ToS SIP: CS3
IP ToS RTP audio: EF
IP ToS RTP video: AF41
IP ToS RTP text: CS0
802.1p CoS SIP: 4
802.1p CoS RTP audio: 5
802.1p CoS RTP video: 6
802.1p CoS RTP text: 5
Jitterbuffer enabled: No

Network Settings:

SIP address remapping: Enabled using externaddr
Externhost:
Externaddr: x.x.x.x:0
Externrefresh: 10
Localnet: 192.168.1.0/255.255.255.0
192.168.1.0/255.255.255.0

Global Signalling Settings:

Codecs: (ulaw)
Codec Order: ulaw:20
Relax DTMF: No
RFC2833 Compensation: No
Symmetric RTP: Yes
Compact SIP headers: No
RTP Keepalive: 0 (Disabled)
RTP Timeout: 30
RTP Hold Timeout: 300
MWI NOTIFY mime type: application/simple-message-summary
DNS SRV lookup: No
Pedantic SIP support: Yes
Reg. min duration 60 secs
Reg. max duration: 3600 secs
Reg. default duration: 120 secs
Outbound reg. timeout: 20 secs
Outbound reg. attempts: 0
Notify ringing state: Yes
Include CID: No
Notify hold state: Yes
SIP Transfer mode: open
Max Call Bitrate: 384 kbps
Auto-Framing: No
Outb. proxy:
Session Timers: Accept
Session Refresher: uas
Session Expires: 1800 secs
Session Min-SE: 90 secs
Timer T1: 500
Timer T1 minimum: 100
Timer B: 32000
No premature media: Yes
Max forwards: 70

Default Settings:

Allowed transports: UDP
Outbound transport: UDP
Context: from-sip-external
Force rport: Yes
DTMF: rfc2833
Qualify: 0
Use ClientCode: No
Progress inband: Never
Language:
MOH Interpret: default
MOH Suggest:
Voice Mail Extension: *97

Tested with the SIP provider and they said they were not even receiving an invite.

They will need that invite (on port 5060 by default) :wink: this is not Asterisk/FreePBX, just as almost always, your network/router setup.

I don’t see how it can be the router. 5060 UDP is forwarded to the FreePBX server. I see the calls being placed and when I login to the SIP provider, I see them in the log. I just don’t have any audio.

Is there a way I can make sure the invite is being sent from the server?

Whether you believe you have mis-configured your router or not, I postulate you have.

Back to basics, as to Invites, of course you can, from Asterisk CLI

sip set debug on

will expose your sip transactions, As to ‘no audio’

rtp set debug on

will expose your rtp traffic (or lack of it)

WEhen you see what is not working, then from bash (after you man tcpdump)

tcpdump

will clue you what you have mis-configured.

Sorry, just thinking out loud. I appreciate all the help, truly. To bring you up to date, I was remote testing this phone. Today I am in the office. I changed my IP address for the SIP server to the internal address and I upgraded the other Polycom Soundpoint IP 321 to 4.0.3f and performed the simple setup.

I can call in and out, as before but now I hear voice oubound, not inbound. With my limited knowledge, it tells me RTP traffic is not able to come in, so it points to what you’re saying that the router could be blocking it.

I’m using an ASUS RT-AC66U router. It say, to forward a range of ports: “If you want to specify a Port Range for clients on the same network, enter the Service Name, the Port Range (e.g. 10200:10300), the LAN IP address, and leave the Local Port empty.”

So, I have: (blank) means left blank
SIP 5060:5082 192.168.1.6 (blank) UDP
RTP 10001:110001 192.168.1.6 (blank) UDP

I brought another router just in case it is the way the router forwards ports.
Thank you for the debug info. I’m running that now.

The SIP provider said this was an issue but I don’t know why it’s sending it this way.
From: sip:[email protected]:5060;tag=192.168.22.50+1+71ea01+969da854
To: sip:[email protected]:5060;tag=as4ff21d6d

I also don’t know where 192.168.22.50 is coming from unless that’s on their end. They were taking issue with [email protected]… It seems I have something missing in my settings.

let’s try that again

From: <sip:[email protected]:5060>;tag=192.168.22.50+1+71ea01+969da854
To: <sip:[email protected]:5060>;tag=as4ff21d6d

One more time

From: [sip:[email protected]:5060];tag=192.168.22.50+1+71ea01+969da854
To: [sip:[email protected]:5060];tag=as4ff21d6d

SIP dump

(— SIP read from UDP:192.168.1.121:5060 —)
BYE sip:[email protected]:5060 SIP/2.0
Via: SIP/2.0/UDP 192.168.1.121;branch=z9hG4bKfd9be786C9EA22B1
From: “201” [sip:[email protected]];tag=1C4B68E4-2ED35C27
To: “ROLAND HALL” [sip:[email protected]];tag=as0327a795
CSeq: 1 BYE
Call-ID: [email protected]:5060
Contact: [sip:[email protected]]
User-Agent: PolycomSoundPointIP-SPIP_321-UA/4.0.3.7562
Accept-Language: en
Max-Forwards: 70
Content-Length: 0

— (11 headers 0 lines) —
Sending to 192.168.1.121:5060 (NAT)
Scheduling destruction of SIP dialog ‘[email protected]:5060’ in 6400 ms (Method: BYE)

(— Transmitting (NAT) to 192.168.1.121:5060 —)
SIP/2.0 200 OK
Via: SIP/2.0/UDP 192.168.1.121;branch=z9hG4bKfd9be786C9EA22B1;received=192.168.1.121;rport=5060
From: “201” [sip:[email protected]];tag=1C4B68E4-2ED35C27
To: “ROLAND HALL” [sip:[email protected]];tag=as0327a795
Call-ID: [email protected]:5060
CSeq: 1 BYE
Server: FPBX-2.10.1(10.12.0)
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH
Supported: replaces, timer
Content-Length: 0

I just found a port forwarding log on the router which shows it’s correct
Destination Proto. Port range Redirect to Local port
ALL TCP 8080 192.168.1.1 80
ALL TCP 8443 192.168.1.1 8443
ALL TCP 22 192.168.1.6 22
ALL UDP 4569 192.168.1.6 4569
ALL UDP 5060:5082 192.168.1.6 5060:5082
ALL UDP 10001:11001 192.168.1.6 10001:11001

FYI… I had a VPN connection from my office to this one. I kept seeing an address that shouldn’t be there and realized it was the VPN local address. I logged in remotely and disconnected it. I then tried calling and voice worked in and out. I hung up, made another call, and it all went to hell. I think Murphy might be shoulder surfing.

OK, I wasn’t going crazy[er]. I can call in from my cell phone, put the phone on speaker, walk in the other room and talk and I can hear it come out of the phone, yet when anyone else calls in, it doesn’t work. So, it only likes me or has a microphone pickup the NSA would kill for. Calling out to my cell phone still only works in one direction. I cannot hear on the IP phone if I call out but they can hear me.

I found a document that talked about PAT (port address translation) and another claiming that FreePBX didn’t respect the RTP port designations in rtp.conf. The first document said addresses ranges being used for communication were coming in around 35k to 44k and when he set his RTP range up to 45K it worked.

That didn’t work for me but I had the same issue. I saw requests coming from 2222 and 2225 targeted at 43k. The second document has a reply from someone that said it must be PAT on top of NAT and to turn it off. He didn’t have a way to do that nor did I so I switched out the router and that solved the issue. I could then send and receive calls with audio in both directions.

For those of you who have audio problems where it’s either no audio in one direction (usually IN) or both, do this to verify:

SSH into your SIP server
asterisk -r
rtp set debug on

Now, make a call. Best to set your SSH client (I used Putty) to log your session to a file. If you see requests coming outside the RTP range, you probably have the same PAT issue. If the router does not allow you to disable it, replace it with one where it can be disabled or doesn’t apply PAT on top of NAT.

Thanks to dicko for pointing it to the router.