FreePBX lost connection to database and asterisk

Hi all,
I have a Raspberry pi 3b running RasPBX. The other day I was trying to make a backup but ran out of space. After that the frontend came up with errors and it seemed to have lost connection to the database. I checked and mariadb/mysql wasn’t running and refused to start. I tried to update and upgrade but it didn’t find the repo. I managed to update at least something but ended up losing asterisk or at least it didn’t work. I got Mariadb up and running again and ended up reinstalling asterisk. I finally got the phonesystem to work but I can’t get it to access recordings to play. This business is closed over Christmas and we had a greeting ready, and I can see it in RasPBX but asterisk (-rvvv) says there is no such file or folder, custom/nameoffile. I am pretty sure that this is some permission problem but I’m not sure where to begin or what to do. Any ideas?
I think it is running an old version of Debian, Jessie.

It think it seems like a permissions issue after a space problem. You should consider checking folder access or restoring backups for recordings paybyplatema

Thank you. I also think this is a permission thing. What user and what group is supposed to have access to the recordings? Or is there a way to have the system rectify it self?

fwconsole chown should fix permissions in asterisk related directories. Eitherway, make sure it is owned by the asterisk user and group

I’ve done fwconsole chown, but that did not fix it. Most of the directories and files are owned by asterisk:asterisk or asterisk:staff.
asterisk.conf does not contain astdatadir=…
Doesn’t that have be in there?

Looks like your files got corrupted. TBH, I am not entirely sure how RasPBX does their install. Their forums may be more helpful: Forum | Asterisk for Raspberry Pi

In any case, if you have a backup, try restoring. Regular FreePBX backups contains the asterisk conf files

Thank you. I have restored but this is still missing. I’ll have a look at another rasppbx I have access to, to see the conf file there.

I compared the asterisk.conf files and the permissions and they are the same. Still not playing the recording. I have decided to setup FreePBX on a “proper” PC (HP mini desktop) and retire the RaspberryPi.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.