FreePBX long time for applying config

I have a FreePBX 2.11 and about 2000 extensions.
When I make BULK extensions and then press Apply config it takes about 2 hours for applying.
the main process /var/lib/asterisk/bit/retrieve_conf continues during all of the time.

And even after I’ve get the result when I just make minor changes in the system, again Apply config takes 2 hours.
In earlier version 2.8 it works quickly and takes about a minute.

Please assist.

Is your DNS working?

the same action but within 5 extensions takes about 10 seconds.
Interesting that I’ve tried perform Ally Changes with 2000 extensions on the lastest version of Elastix and there was no problem (took a minute). Only on FreePBX Distro I have such problem.

sorry this Button is called “Apply Config”

I have only seen this issue when DNS is not working and Asterisk is timing out with each line of the reload on a DNS lookup. What does the Asterisk console look like during the reload with the verbosity turned up?

strange… but I had entered to the console and set verbosity as 9.
then I had made some changes on the web interface and after that pressed Apply Config, but I don’t see anything in the Asterisk at all. I mean there is quietly at all. Asterisk does not send any logs to my console.
htop command shows that process /usr/bin/php -q /var/lib/asterisk/bin/retrieve_conf takes 100% of CPU resources and lasts during this 2 hours.

Looks like we’ve encountered the same issue

I’ve tried to perform specified actions in that request but the versions of FreePBXs are different.
And the fulfill of files is not the same. So it does not help.

Do you have the Digium Phones module installed. If so remove it and try.

it works! thank you a lot!
now it takes about 3 mins.
Can you please explain in details why when I enable this module it increases the time of Applying Config.

Thanks in advance!

Ask Digium. It is a module built by them but we have noticed this and reported it to them months ago.