FreePBX keeps blocking my IP

Hi

Ive noticed that if I try to register my Xlite client wrong twice it blocks the IP im trying from. If I try to ping, do http request or register a sip device again wireshark tells me (destination not reachable) but as soon as I try from a vmware desktop pc it works fine. If I reboot the FreePBX server the connection is working again.

Ive tried to uninstall the firewall module and the blocklist module but to no help. Is there any way I can get FreePBX to NOT block any IP? Im doing some testing and register faults will happen…

Fail2ban is banning your IP’s.

Under System Admin > Intrusions Detection You can white list your network eg 192.168.1.0/24 or ip 192.168.1.145.
Once a IP is already banned you have to hit restart after whitlisting the IP.

Blacklist if blacklisting phone numbers, not IP’s and also not automatically… He’s crying now.

EDIT: See this wiki https://wiki.freepbx.org/display/FPG/System+Admin+-+Intrusion+Detection

1 Like

I’ve been down this road recently and in some cases even whitelisting and restarting did not remove the IP from the ban list. I had to manually clear the ban. I did so through SSH.

show list: “iptables -L fail2ban-SIP”

Delete: “iptables -D fail2ban-SIP #” (where # is the sequence number of the IP you want to clear)

1 Like

Thanks PitzKey and eros18 for your response!

I fixed the issue by adding the subnet (CIDR) of my lab in the whitelist, now it works.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.